summaryrefslogtreecommitdiff
path: root/gnu/packages/qt.scm
diff options
context:
space:
mode:
authorJakub Kądziołka <kuba@kadziolka.net>2020-07-25 23:05:33 +0200
committerJakub Kądziołka <kuba@kadziolka.net>2020-08-05 02:16:17 +0200
commitab6fe9d362046231ad6f46eccfd1ea2c9c80b401 (patch)
treef2ba3c607d02f6b92ee0cf78f1daebb336507f7f /gnu/packages/qt.scm
parent08683393c37e947ca119c72911bec7cfca0fad85 (diff)
downloadguix-patches-ab6fe9d362046231ad6f46eccfd1ea2c9c80b401.tar
guix-patches-ab6fe9d362046231ad6f46eccfd1ea2c9c80b401.tar.gz
gnu: qtbase: Provide debug symbols.
* gnu/packages/qt.scm (qtbase)[outputs]: Add "debug". [arguments]: Add "-force-debug-info" to configure flags.
Diffstat (limited to 'gnu/packages/qt.scm')
-rw-r--r--gnu/packages/qt.scm4
1 files changed, 4 insertions, 0 deletions
diff --git a/gnu/packages/qt.scm b/gnu/packages/qt.scm
index 949d56d87b..ee903ecae9 100644
--- a/gnu/packages/qt.scm
+++ b/gnu/packages/qt.scm
@@ -368,6 +368,7 @@ developers using C++ or QML, a CSS & JavaScript like language.")
"zlib"))
#t)))))
(build-system gnu-build-system)
+ (outputs '("out" "debug"))
(propagated-inputs
`(("mesa" ,mesa)
;; Use which the package, not the function
@@ -474,6 +475,9 @@ developers using C++ or QML, a CSS & JavaScript like language.")
"-opensource"
"-confirm-license"
+ ;; Later stripped into the :debug output.
+ "-force-debug-info"
+
;; These features require higher versions of Linux than the
;; minimum version of the glibc. See
;; src/corelib/global/minimum-linux_p.h. By disabling these