summaryrefslogtreecommitdiff
path: root/gnu/packages/qt.scm
diff options
context:
space:
mode:
authorJohn Doe <dftxbs3e@free.fr>2020-12-27 23:26:46 +0100
committerEfraim Flashner <efraim@flashner.co.il>2020-12-28 13:21:13 +0200
commita942ab183782bbdf785bd73f70f7ec905764f941 (patch)
tree00c1b2bd7fdbfad64959fddca7bdfe7bd9f67eb7 /gnu/packages/qt.scm
parent98471d578679e25fd9c28097ea017aa4035ae8dd (diff)
downloadguix-patches-a942ab183782bbdf785bd73f70f7ec905764f941.tar
guix-patches-a942ab183782bbdf785bd73f70f7ec905764f941.tar.gz
gnu: Add python-qtpy.
* gnu/packages/qt.scm (python-qtpy): New variable. Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
Diffstat (limited to 'gnu/packages/qt.scm')
-rw-r--r--gnu/packages/qt.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/qt.scm b/gnu/packages/qt.scm
index 2e621e758c..9a5b329f4d 100644
--- a/gnu/packages/qt.scm
+++ b/gnu/packages/qt.scm
@@ -2268,6 +2268,31 @@ itself.")
"--sipdir" sip)))))))
(license (list license:gpl2 license:gpl3)))) ; choice of either license
+(define-public python-qtpy
+ (package
+ (name "python-qtpy")
+ (version "1.9.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "QtPy" version))
+ (sha256
+ (base32
+ "13cw8l7zrhbdi03k1wl1pg9xdl4ahdfa7yz8gd0f23sxnm22rdrd"))))
+ (build-system python-build-system)
+ (propagated-inputs
+ `(("python-pyside2" ,python-pyside-2)))
+ (arguments
+ `(;; Not all supported bindings are packaged. Especially PyQt4.
+ #:tests? #f))
+ (home-page "https://github.com/spyder-ide/qtpy")
+ (synopsis
+ "Qt bindings (PyQt5, PyQt4 and PySide) and additional custom QWidgets")
+ (description
+ "Provides an abstraction layer on top of the various Qt bindings
+(PyQt5, PyQt4 and PySide) and additional custom QWidgets.")
+ (license license:expat)))
+
(define-public qscintilla
(package
(name "qscintilla")