summaryrefslogtreecommitdiff
path: root/gnu/packages/qt.scm
diff options
context:
space:
mode:
authorEkaitz Zarraga <ekaitz@elenq.tech>2021-01-01 15:17:06 +0100
committerLeo Famulari <leo@famulari.name>2021-01-03 19:12:46 -0500
commita5f13705cb9261ab66bdf73d1fb4a832714feb31 (patch)
tree374a42d25e80cffe0beda5cbd929621b371ee292 /gnu/packages/qt.scm
parent708a610e45ab06844916c73ca0ea37e7810bd3c4 (diff)
downloadguix-patches-a5f13705cb9261ab66bdf73d1fb4a832714feb31.tar
guix-patches-a5f13705cb9261ab66bdf73d1fb4a832714feb31.tar.gz
gnu: Add soqt.
* gnu/packages/qt.scm (soqt): New variable. Signed-off-by: Leo Famulari <leo@famulari.name>
Diffstat (limited to 'gnu/packages/qt.scm')
-rw-r--r--gnu/packages/qt.scm33
1 files changed, 33 insertions, 0 deletions
diff --git a/gnu/packages/qt.scm b/gnu/packages/qt.scm
index 0b94063373..79d41b3e73 100644
--- a/gnu/packages/qt.scm
+++ b/gnu/packages/qt.scm
@@ -67,6 +67,7 @@
#:use-module (gnu packages glib)
#:use-module (gnu packages gnupg)
#:use-module (gnu packages gperf)
+ #:use-module (gnu packages graphics)
#:use-module (gnu packages gstreamer)
#:use-module (gnu packages gtk)
#:use-module (gnu packages icu4c)
@@ -2850,3 +2851,35 @@ being fully customizable and easy to extend.")
;; According to LICENSE, either version 2 or version 3 of the GNU GPL may
;; be used.
(license (list license:gpl2 license:gpl3))))
+
+
+(define-public soqt
+ (let ((commit-ref "fb8f655632bb9c9c60e0ff9fa69a5ba22d3ff99d")
+ (revision "1"))
+ (package
+ (name "soqt")
+ (version (git-version "1.6.0" revision commit-ref))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/coin3d/soqt")
+ (commit commit-ref)
+ (recursive? #t)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "16vikb3fy8rmk10sg5g0gy2c343hi3x7zccsga90ssnkzpq6m032"))))
+ (build-system cmake-build-system)
+ (arguments '(#:tests? #f)) ; There are no tests
+ (native-inputs
+ `(("pkg-config" ,pkg-config)
+ ("cmake" ,cmake)))
+ (inputs
+ `(("qtbase" ,qtbase)
+ ("coin3D" ,coin3D-4)))
+ (home-page "https://github.com/coin3d/soqt")
+ (synopsis "Qt GUI component toolkit library for Coin")
+ (description "SoQt is a Qt GUI component toolkit library for Coin. It is
+also compatible with SGI and TGS Open Inventor, and the API is based on the API
+of the InventorXt GUI component toolkit.")
+ (license license:bsd-3))))