summaryrefslogtreecommitdiff
path: root/gnu/packages/qt.scm
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2020-06-07 22:38:30 +0200
committerMarius Bakke <marius@gnu.org>2020-06-07 22:38:30 +0200
commit8cbb32da7dfa53b15f2ecec7361e24961bb93bbc (patch)
tree60d7a52063f1ef5a39f249abec6d97c870716caf /gnu/packages/qt.scm
parent9097f994483dc8abb786fb3b8ad5cc73484e9f24 (diff)
downloadguix-patches-8cbb32da7dfa53b15f2ecec7361e24961bb93bbc.tar
guix-patches-8cbb32da7dfa53b15f2ecec7361e24961bb93bbc.tar.gz
gnu: python-sip: Use PYTHON-VERSION.
* gnu/packages/qt.scm (python-sip)[arguments]: Add #:imported-modules. Rewrite phase to use PYTHON-VERSION instead of custom implementation.
Diffstat (limited to 'gnu/packages/qt.scm')
-rw-r--r--gnu/packages/qt.scm11
1 files changed, 4 insertions, 7 deletions
diff --git a/gnu/packages/qt.scm b/gnu/packages/qt.scm
index 31f6134d96..2b3096a04e 100644
--- a/gnu/packages/qt.scm
+++ b/gnu/packages/qt.scm
@@ -1901,7 +1901,10 @@ and binaries removed, and adds modular support for using system libraries.")
`(("python" ,python-wrapper)))
(arguments
`(#:tests? #f ; no check target
+ #:imported-modules ((guix build python-build-system)
+ ,@%gnu-build-system-modules)
#:modules ((srfi srfi-1)
+ ((guix build python-build-system) #:select (python-version))
,@%gnu-build-system-modules)
#:phases
(modify-phases %standard-phases
@@ -1911,14 +1914,8 @@ and binaries removed, and adds modular support for using system libraries.")
(bin (string-append out "/bin"))
(include (string-append out "/include"))
(python (assoc-ref inputs "python"))
- (python-version
- (last (string-split python #\-)))
- (python-major+minor
- (string-join
- (take (string-split python-version #\.) 2)
- "."))
(lib (string-append out "/lib/python"
- python-major+minor
+ (python-version python)
"/site-packages")))
(invoke "python" "configure.py"
"--bindir" bin