summaryrefslogtreecommitdiff
path: root/gnu/packages/qt.scm
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2019-11-08 11:14:52 +0100
committerHartmut Goebel <h.goebel@crazy-compilers.com>2019-11-10 21:27:09 +0100
commit8bfd7c8beb75ed3838efdf5973b9db5fb3ced68c (patch)
tree46477fd9be23a28732db313e359455c277f96242 /gnu/packages/qt.scm
parentea57bb893eeb7008064d2f511dede616d4bdcbd1 (diff)
downloadguix-patches-8bfd7c8beb75ed3838efdf5973b9db5fb3ced68c.tar
guix-patches-8bfd7c8beb75ed3838efdf5973b9db5fb3ced68c.tar.gz
gnu: qtwebkit: Use sqlite-with-column-metadata.
This needs to be the same variant as for qtbase, otherwise applications might fail if libQt5WebKit is loaded prior to libQt5Sql. * gnu/packages/qt.scm(wtwebkit)[inputs]: Replace sqlite by sqlite-with-column-metadata.
Diffstat (limited to 'gnu/packages/qt.scm')
-rw-r--r--gnu/packages/qt.scm2
1 files changed, 1 insertions, 1 deletions
diff --git a/gnu/packages/qt.scm b/gnu/packages/qt.scm
index 0ef879678f..222a0cc867 100644
--- a/gnu/packages/qt.scm
+++ b/gnu/packages/qt.scm
@@ -2182,7 +2182,7 @@ different kinds of sliders, and much more.")
("libjpeg" ,libjpeg)
("libpng" ,libpng)
("libwebp" ,libwebp)
- ("sqlite" ,sqlite)
+ ("sqlite" ,sqlite-with-column-metadata)
("fontconfig" ,fontconfig)
("libxrender" ,libxrender)
("qtbase" ,qtbase)