summaryrefslogtreecommitdiff
path: root/gnu/packages/qt.scm
diff options
context:
space:
mode:
authorGuillaume Le Vaillant <glv@posteo.net>2021-09-11 10:54:22 +0200
committerGuillaume Le Vaillant <glv@posteo.net>2021-09-11 10:54:22 +0200
commit856591e2b50cb5f186f01b252be239ae7553eeef (patch)
treeb8cdb3b1c588108160d23a8ffc7d01a91de3b4e4 /gnu/packages/qt.scm
parenteded8b4f1718470fe132288ed5446563bdacbe2f (diff)
downloadguix-patches-856591e2b50cb5f186f01b252be239ae7553eeef.tar
guix-patches-856591e2b50cb5f186f01b252be239ae7553eeef.tar.gz
gnu: materialdecoration: Fix build.
* gnu/packages/qt.scm (materialdecoration)[arguments]: Use gexp for 'configure-flags'.
Diffstat (limited to 'gnu/packages/qt.scm')
-rw-r--r--gnu/packages/qt.scm11
1 files changed, 6 insertions, 5 deletions
diff --git a/gnu/packages/qt.scm b/gnu/packages/qt.scm
index 1f05ab5db1..5ce4220cb0 100644
--- a/gnu/packages/qt.scm
+++ b/gnu/packages/qt.scm
@@ -49,6 +49,7 @@
#:use-module (guix build-system trivial)
#:use-module (guix build-system python)
#:use-module (guix build-system qt)
+ #:use-module (guix gexp)
#:use-module (guix packages)
#:use-module (guix deprecation)
#:use-module (guix utils)
@@ -221,11 +222,11 @@ window managers, that don't provide Qt integration by themselves.")
(arguments
`(#:tests? #f ; No target
#:configure-flags
- (list
- (string-append "-DCMAKE_CXX_FLAGS=-I"
- (assoc-ref %build-inputs "qtbase")
- "/include/qt5/QtXkbCommonSupport/"
- ,(package-version qtbase-5)))))
+ ,#~(list
+ (string-append "-DCMAKE_CXX_FLAGS=-I"
+ #$(this-package-input "qtbase")
+ "/include/qt5/QtXkbCommonSupport/"
+ #$(package-version qtbase-5)))))
(native-inputs
`(("cmake-shared" ,cmake-shared)
("extra-cmake-modules" ,extra-cmake-modules)