summaryrefslogtreecommitdiff
path: root/gnu/packages/qt.scm
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2020-06-07 22:42:27 +0200
committerMarius Bakke <marius@gnu.org>2020-06-07 22:42:27 +0200
commit7c7e9ac71662013348e5acb78c8df3d6ab718ad0 (patch)
treefb697a2c7647e6070ead1f495470d4d59536ce55 /gnu/packages/qt.scm
parent3c48fe3658474492307d76f400dc22c98d2a05b7 (diff)
downloadguix-patches-7c7e9ac71662013348e5acb78c8df3d6ab718ad0.tar
guix-patches-7c7e9ac71662013348e5acb78c8df3d6ab718ad0.tar.gz
gnu: python-pyqtwebengine: Update to 5.14.0.
* gnu/packages/qt.scm (python-pyqtwebengine): Update to 5.14.0. [source](uri): Add PyPI mirror.
Diffstat (limited to 'gnu/packages/qt.scm')
-rw-r--r--gnu/packages/qt.scm13
1 files changed, 8 insertions, 5 deletions
diff --git a/gnu/packages/qt.scm b/gnu/packages/qt.scm
index fb9643bfd3..d777048046 100644
--- a/gnu/packages/qt.scm
+++ b/gnu/packages/qt.scm
@@ -2037,16 +2037,19 @@ contain over 620 classes.")
(define-public python-pyqtwebengine
(package
(name "python-pyqtwebengine")
- (version "5.12.1")
+ (version "5.14.0")
(source
(origin
(method url-fetch)
- (uri (string-append
- "https://www.riverbankcomputing.com/static/Downloads/PyQtWebEngine/"
- version "/PyQtWebEngine_gpl-" version ".tar.gz"))
+ ;; The newest releases are only available on PyPI. Older ones
+ ;; are mirrored at the upstream home page.
+ (uri (list (pypi-uri "PyQtWebEngine" version)
+ (string-append "https://www.riverbankcomputing.com/static"
+ "/Downloads/PyQtWebEngine/" version
+ "/PyQtWebEngine-" version ".tar.gz")))
(sha256
(base32
- "0wylkd7fh2g27y3710rpxmj9wx0wpi3z7qbv6khiddm15rkh81w6"))))
+ "14hw49akb35n9pgiw564x8ykmsifihn9p2ax2x4zmywb3w2ra5g1"))))
(build-system gnu-build-system)
(native-inputs
`(("python" ,python)