summaryrefslogtreecommitdiff
path: root/gnu/packages/qt.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2019-09-06 22:58:26 +0200
committerLudovic Courtès <ludo@gnu.org>2019-09-07 00:36:34 +0200
commit4961364f1681ea5c3fc7a988b4f48db448338cb8 (patch)
tree09bc50d8bc4934787d0d256bd0ef7ca89c9b17ca /gnu/packages/qt.scm
parent61acb764eddb303ef5836c3b5a4bb9b6c718d4ff (diff)
downloadguix-patches-4961364f1681ea5c3fc7a988b4f48db448338cb8.tar
guix-patches-4961364f1681ea5c3fc7a988b4f48db448338cb8.tar.gz
gnu: qtwebkit: Disable non-x86 builds.
* gnu/packages/qt.scm (qtwebkit)[supported-systems]: New field.
Diffstat (limited to 'gnu/packages/qt.scm')
-rw-r--r--gnu/packages/qt.scm6
1 files changed, 6 insertions, 0 deletions
diff --git a/gnu/packages/qt.scm b/gnu/packages/qt.scm
index 52eb46cce0..165b8fd7b4 100644
--- a/gnu/packages/qt.scm
+++ b/gnu/packages/qt.scm
@@ -2212,6 +2212,12 @@ time Web content can be enhanced with native controls.")
;; Building QtWebKit takes around 13 hours on an AArch64 machine. Give some
;; room for slower or busy hardware.
(properties '((timeout . 64800))) ;18 hours
+
+ ;; XXX: This consumes too much RAM to successfully build on AArch64 (e.g.,
+ ;; SoftIron OverDrive with 8 GiB of RAM), so instead of wasting resources,
+ ;; disable it on non-Intel platforms.
+ (supported-systems '("x86_64-linux" "i686-linux"))
+
(license license:lgpl2.1+)))
(define-public dotherside