summaryrefslogtreecommitdiff
path: root/gnu/packages/qt.scm
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2018-05-30 19:37:25 +0200
committerHartmut Goebel <h.goebel@crazy-compilers.com>2018-06-12 22:47:01 +0200
commit359e30c9ea8985738c3dc1057438abb7215d608b (patch)
tree7c62b2db9da7a4173d29862c88c4e0cad368d3f3 /gnu/packages/qt.scm
parent25e071ead9ddf701485750eec41fd869e310eab0 (diff)
downloadguix-patches-359e30c9ea8985738c3dc1057438abb7215d608b.tar
guix-patches-359e30c9ea8985738c3dc1057438abb7215d608b.tar.gz
gnu: Add qtwebview.
* gnu/packages/qt.scm (qtwebview): New variable.
Diffstat (limited to 'gnu/packages/qt.scm')
-rw-r--r--gnu/packages/qt.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/qt.scm b/gnu/packages/qt.scm
index 7d323cd2d5..107b5dff49 100644
--- a/gnu/packages/qt.scm
+++ b/gnu/packages/qt.scm
@@ -9,6 +9,7 @@
;;; Copyright © 2017 Quiliro <quiliro@fsfla.org>
;;; Copyright © 2017, 2018 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2018 Nicolas Goaziou <mail@nicolasgoaziou.fr>
+;;; Copyright © 2018 Hartmut Goebel <h.goebel@crazy-compilers.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -1069,6 +1070,29 @@ between the host (QML/C++ application) and the client (HTML/JavaScript
application). The transport mechanism is supported out of the box by the two
popular web engines, Qt WebKit 2 and Qt WebEngine.")))
+(define-public qtwebview
+ (package (inherit qtsvg)
+ (name "qtwebview")
+ (version "5.11.0")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://download.qt.io/official_releases/qt/"
+ (version-major+minor version) "/" version
+ "/submodules/" name "-everywhere-src-"
+ version ".tar.xz"))
+ (sha256
+ (base32
+ "0a89v8mj5pb7a7whyhasf4ms0n34ghfmv2qp0pyxnq56f2bsjbl4"))))
+ (native-inputs
+ `(("perl" ,perl)))
+ (inputs
+ `(("qtbase" ,qtbase)
+ ("qtdeclarative" ,qtdeclarative)))
+ (synopsis "Display web content in a QML application")
+ (description "Qt WebView provides a way to display web content in a QML
+application without necessarily including a full web browser stack by using
+native APIs where it makes sense.")))
+
(define-public qtlocation
(package (inherit qtsvg)
(name "qtlocation")