summaryrefslogtreecommitdiff
path: root/gnu/packages/python.scm
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2018-12-10 16:22:25 +0100
committerChristopher Baines <mail@cbaines.net>2018-12-12 09:03:27 +0100
commitf6c19fe8ce9ba767ceb62b9f2ef3b8fb3b5ac8c5 (patch)
tree1cd1dc645f7fa877b26f3a85d13467a560484bb0 /gnu/packages/python.scm
parenta65a33d070285bd8fdfab301089e100b41fee867 (diff)
downloadguix-patches-f6c19fe8ce9ba767ceb62b9f2ef3b8fb3b5ac8c5.tar
guix-patches-f6c19fe8ce9ba767ceb62b9f2ef3b8fb3b5ac8c5.tar.gz
gnu: python-kombu: Update to 4.2.2.
This fixes the build, that probably broke with a Python update. * gnu/packages/python.scm (python-kombu): Update to 4.2.2..
Diffstat (limited to 'gnu/packages/python.scm')
-rw-r--r--gnu/packages/python.scm11
1 files changed, 7 insertions, 4 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 2c87e1a09d..53ab6d35ea 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -8337,23 +8337,26 @@ applications.")
(define-public python-kombu
(package
(name "python-kombu")
- (version "3.0.37")
+ (version "4.2.2")
(source
(origin
(method url-fetch)
(uri (pypi-uri "kombu" version))
(sha256
(base32
- "0l16chb314gpq2v7fh94a22c30lcv6w3ylmhsa60bldlcq6a0r70"))))
+ "15k8f7mzqr049sg9vi48m19vjykviafk3f0p5xzgw9by0x0kyxjj"))))
(build-system python-build-system)
(native-inputs
`(("python-mock" ,python-mock)
- ("python-nose" ,python-nose)))
+ ("python-case" ,python-case)
+ ("python-pyro4" ,python-pyro4)
+ ("python-pytest-sugar" ,python-pytest-sugar)
+ ("python-pytz" ,python-pytz)))
(propagated-inputs
`(("python-anyjson" ,python-anyjson)
("python-amqp" ,python-amqp)
("python-redis" ,python-redis)))
- (home-page "http://kombu.readthedocs.org")
+ (home-page "https://kombu.readthedocs.io")
(synopsis "Message passing library for Python")
(description "The aim of Kombu is to make messaging in Python as easy as
possible by providing an idiomatic high-level interface for the AMQ protocol,