summaryrefslogtreecommitdiff
path: root/gnu/packages/python.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2020-10-21 22:27:30 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-01-12 22:00:42 -0500
commitf1eea19c9ae27e5d275b083bbf280e5b59e5e57a (patch)
tree3258a8b8303ad3cf11e6cdab45f02a1aa0735525 /gnu/packages/python.scm
parent44b0ffcf00f2150c120ecf82003ab10a93fe2184 (diff)
downloadguix-patches-f1eea19c9ae27e5d275b083bbf280e5b59e5e57a.tar
guix-patches-f1eea19c9ae27e5d275b083bbf280e5b59e5e57a.tar.gz
gnu: python-3.8: Apply python-3-arm-alignment.patch unconditionally.
* gnu/packages/python.scm (python-3.8)[source]: Add "python-3-arm-alignment.patch" to the patches field. [phases]{apply-alignment-patch}: Remove phase. [native-inputs]: Remove arm-alignment.patch.
Diffstat (limited to 'gnu/packages/python.scm')
-rw-r--r--gnu/packages/python.scm27
1 files changed, 2 insertions, 25 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index c0686b0128..25ad86f204 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -371,6 +371,7 @@ data types.")
(uri (string-append "https://www.python.org/ftp/python/"
version "/Python-" version ".tar.xz"))
(patches (search-patches
+ "python-3-arm-alignment.patch"
"python-3-fix-tests.patch"
"python-3.8-fix-tests.patch"
"python-3-deterministic-build-info.patch"
@@ -473,33 +474,9 @@ data types.")
,file)))
(find-files out "\\.py$")))
(list '() '("-O") '("-OO")))
- #t)))
- ;; XXX: Apply patch on ARM platforms only to avoid a full rebuild.
- ;; Remove this phase in the next rebuild cycle.
- ,@(let ((system (or (%current-target-system)
- (%current-system))))
- (if (any (cute string-prefix? <> system)
- '("arm" "aarch64"))
- '((add-after 'unpack 'apply-alignment-patch
- (lambda* (#:key native-inputs inputs #:allow-other-keys)
- (invoke "patch" "-p1" "--force" "--input"
- (assoc-ref (or native-inputs inputs)
- "arm-alignment.patch")))))
- '()))))))
+ #t)))))))
(native-inputs
`(("tzdata" ,tzdata-for-tests)
-
- ;; Disable unaligned accesses in the sha3 module on ARM as
- ;; it causes a test failure when building 32-bit Python on a
- ;; 64-bit kernel. See <https://bugs.python.org/issue36515>.
- ;; TODO: make this a regular patch in the next rebuild cycle.
- ,@(let ((system (or (%current-target-system)
- (%current-system))))
- (if (any (cute string-prefix? <> system)
- '("arm" "aarch64"))
- `(("arm-alignment.patch" ,(search-patch "python-3-arm-alignment.patch")))
- '()))
-
,@(if (%current-target-system)
`(("python3" ,this-package))
'())