summaryrefslogtreecommitdiff
path: root/gnu/packages/python.scm
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2021-07-21 23:54:10 +0200
committerMarius Bakke <marius@gnu.org>2021-07-23 17:26:46 +0200
commitea562aba69d8ef8599abdaf2505e3f1f7ecf4d28 (patch)
tree32f09c59155eec96932a00f66b582031c53a862c /gnu/packages/python.scm
parent09b002622e2113c2f14c11ccd43fa01fd343fb95 (diff)
downloadguix-patches-ea562aba69d8ef8599abdaf2505e3f1f7ecf4d28.tar
guix-patches-ea562aba69d8ef8599abdaf2505e3f1f7ecf4d28.tar.gz
gnu: Python: Do not embed timestamps in wheel files.
* gnu/packages/python.scm (python-3.9)[arguments]: Reset timestamps before zipping wheels. While at it, remove redundant regex argument.
Diffstat (limited to 'gnu/packages/python.scm')
-rw-r--r--gnu/packages/python.scm12
1 files changed, 9 insertions, 3 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 74af5b3445..0ec790223e 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -26,7 +26,7 @@
;;; Copyright © 2016, 2017 Nikita <nikita@n0.is>
;;; Copyright © 2016 Dylan Jeffers <sapientech@sapientech@openmailbox.org>
;;; Copyright © 2016 David Craven <david@craven.ch>
-;;; Copyright © 2016, 2017, 2018, 2019, 2020 Marius Bakke <mbakke@fastmail.com>
+;;; Copyright © 2016, 2017, 2018, 2019, 2020, 2021 Marius Bakke <marius@gnu.org>
;;; Copyright © 2016, 2017 Stefan Reichör <stefan@xsteve.at>
;;; Copyright © 2016 Dylan Jeffers <sapientech@sapientech@openmailbox.org>
;;; Copyright © 2016, 2017 Alex Vong <alexvong1995@gmail.com>
@@ -502,7 +502,8 @@ data types.")
;; Delete .exe from embedded .whl (zip) files
(for-each
(lambda (whl)
- (let ((dir "whl-content"))
+ (let ((dir "whl-content")
+ (circa-1980 (* 10 366 24 60 60)))
(mkdir-p dir)
(with-directory-excursion dir
(let ((whl (string-append "../" whl)))
@@ -510,8 +511,13 @@ data types.")
(for-each delete-file
(find-files "." "\\.exe$"))
(delete-file whl)
+ ;; Reset timestamps to prevent them from ending
+ ;; up in the Zip archive.
+ (ftw "." (lambda (file stat flag)
+ (utime file circa-1980 circa-1980)
+ #t))
(apply invoke "zip" "-X" whl
- (find-files "." ".*" #:directories? #t))))
+ (find-files "." #:directories? #t))))
(delete-file-recursively dir)))
(find-files "Lib/ensurepip" "\\.whl$"))))
(add-before 'check 'set-TZDIR