summaryrefslogtreecommitdiff
path: root/gnu/packages/python.scm
diff options
context:
space:
mode:
authorJan (janneke) Nieuwenhuizen <janneke@gnu.org>2020-10-07 23:01:26 +0200
committerJan (janneke) Nieuwenhuizen <janneke@gnu.org>2020-10-26 15:53:37 +0100
commite6320ba20404d4a6d81e42f96c3792b7122871b0 (patch)
treef155a39012b3dec2bc28e77ea71fecf413f96e82 /gnu/packages/python.scm
parent22213308f3bcc41bd2356ccbb7350a74c1426a0a (diff)
downloadguix-patches-e6320ba20404d4a6d81e42f96c3792b7122871b0.tar
guix-patches-e6320ba20404d4a6d81e42f96c3792b7122871b0.tar.gz
gnu: python: Disable failing tests for the Hurd.
Fixes <https://bugs.gnu.org/43860>. * gnu/packages/python.scm (python-3.8)[arguments]: When building for the Hurd, disable more tests.
Diffstat (limited to 'gnu/packages/python.scm')
-rw-r--r--gnu/packages/python.scm34
1 files changed, 33 insertions, 1 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 8f2651decf..43704bccae 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -395,7 +395,39 @@ data types.")
" --exclude test_mmap"
;; test_socket may hang and eventually run out of memory
;; on some systems: <https://bugs.python.org/issue34587>.
- " test_socket")))
+ " test_socket"
+ ,@(if (hurd-target?)
+ '(" test_posix" ;multiple errors
+ " test_time"
+ " test_pty"
+ " test_shutil"
+ " test_tempfile" ;chflags: invalid argument:
+ ; tbv14c9t/dir0/dir0/dir0/test0.txt
+ " test_asyncio" ;runs over 10min
+ " test_os" ;stty: 'standard input':
+ ; Inappropriate ioctl for device
+ " test_openpty" ;No such file or directory
+ " test_selectors" ;assertEqual(NUM_FDS // 2, len(fds))
+ ; 32752 != 4
+ " test_compileall" ;multiple errors
+ " test_poll" ;list index out of range
+ " test_subprocess" ;runs over 10min
+ " test_asyncore" ;multiple errors
+ " test_threadsignals"
+ " test_eintr" ;Process return code is -14
+ " test_io" ;multiple errors
+ " test_logging"
+ " test_signal"
+ " test_threading" ;runs over 10min
+ " test_flags" ;ERROR
+ " test_bidirectional_pty"
+ " test_create_unix_connection"
+ " test_unix_sock_client_ops"
+ " test_open_unix_connection"
+ " test_open_unix_connection_error"
+ " test_read_pty_output"
+ " test_write_pty")
+ '()))))
((#:phases phases)
`(modify-phases ,phases
,@(if (hurd-system?)