summaryrefslogtreecommitdiff
path: root/gnu/packages/python.scm
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2020-12-21 23:42:10 +0100
committerMarius Bakke <marius@gnu.org>2020-12-21 23:42:10 +0100
commitbbe4ed65ed5fe7dc8ed9d226042852387cee3b1e (patch)
tree9fbf0642fe71d0d4f6d7cb4e85b4d1587c8b9b16 /gnu/packages/python.scm
parent034cfbd2449387c15823cd9ec3e91661f9e5bf49 (diff)
parentf00e68ace070fd5240a4b5874e61c26f6e909b6c (diff)
downloadguix-patches-bbe4ed65ed5fe7dc8ed9d226042852387cee3b1e.tar
guix-patches-bbe4ed65ed5fe7dc8ed9d226042852387cee3b1e.tar.gz
Merge branch 'master' into ungrafting
Diffstat (limited to 'gnu/packages/python.scm')
-rw-r--r--gnu/packages/python.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 533b2bdeff..27e9b70432 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -521,6 +521,31 @@ data types.")
(version-major+minor version)
"/site-packages"))))))))
+(define-public python-3.9
+ (package (inherit python-3.8)
+ (name "python-next")
+ (version "3.9.1")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://www.python.org/ftp/python/"
+ version "/Python-" version ".tar.xz"))
+ (patches (search-patches
+ "python-3.9-fix-tests.patch"
+ "python-3-deterministic-build-info.patch"
+ "python-3-search-paths.patch"))
+ (sha256
+ (base32
+ "1zq3k4ymify5ig739zyvx9s2ainvchxb1zpy139z74krr653y74r"))
+ (modules '((guix build utils)))
+ (snippet
+ '(begin
+ ;; Delete the bundled copy of libexpat.
+ (delete-file-recursively "Modules/expat")
+ (substitute* "Modules/Setup"
+ ;; Link Expat instead of embedding the bundled one.
+ (("^#pyexpat.*") "pyexpat pyexpat.c -lexpat\n"))
+ #t))))))
+
;; Current 3.x version.
(define-public python-3 python-3.8)