summaryrefslogtreecommitdiff
path: root/gnu/packages/python.scm
diff options
context:
space:
mode:
authorTanguy Le Carrour <tanguy@bioneland.org>2019-11-19 09:50:51 +0100
committerMarius Bakke <mbakke@fastmail.com>2019-11-20 00:16:51 +0100
commitaf6a9fc27622ea8a342fe18c8604f2fe64a04e68 (patch)
tree480934e5a9d67309df923b1fbe20e82a4afe0de2 /gnu/packages/python.scm
parent3b7828cc7f938fcb369976cbe75d9c85f22583a1 (diff)
downloadguix-patches-af6a9fc27622ea8a342fe18c8604f2fe64a04e68.tar
guix-patches-af6a9fc27622ea8a342fe18c8604f2fe64a04e68.tar.gz
gnu: Add python-3.8.
* gnu/packages/python.scm (python-3.8): New public variable. [source]: Add patches to skip four tests. * gnu/packages/patches/python-3.8-search-paths.patch: New file. * gnu/packages/patches/python-3.8-fix-tests.patch: New file. Signed-off-by: Marius Bakke <mbakke@fastmail.com>
Diffstat (limited to 'gnu/packages/python.scm')
-rw-r--r--gnu/packages/python.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 644c9d7666..048941e8a9 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -57,6 +57,7 @@
;;; Copyright © 2018, 2019 Maxim Cournoyer <maxim.cournoyer@gmail.com>
;;; Copyright © 2018 Luther Thompson <lutheroto@gmail.com>
;;; Copyright © 2018 Vagrant Cascadian <vagrant@debian.org>
+;;; Copyright © 2019 Tanguy Le Carrour <tanguy@bioneland.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -408,6 +409,31 @@ data types.")
(version-major+minor version)
"/site-packages"))))))))
+(define-public python-3.8
+ (package
+ (inherit python-3.7)
+ (name "python-next")
+ (version "3.8.0")
+ (source
+ (origin
+ (inherit (package-source python-3.7))
+ (uri (string-append "https://www.python.org/ftp/python/"
+ version "/Python-" version ".tar.xz"))
+ (sha256 (base32 "110d0did9rxn7rg85kf2fwli5hqq44xv2d8bi7d92m7v2d728mmk"))
+ (patches (search-patches
+ "python-3.8-search-paths.patch"
+ "python-3-fix-tests.patch"
+ "python-3.8-fix-tests.patch"
+ "python-3-deterministic-build-info.patch"))
+ (snippet
+ '(begin
+ ;; Delete the bundled copy of libexpat.
+ (delete-file-recursively "Modules/expat")
+ (substitute* "Modules/Setup"
+ ;; Link Expat instead of embedding the bundled one.
+ (("^#pyexpat.*") "pyexpat pyexpat.c -lexpat\n"))
+ #t))))))
+
;; Current 3.x version.
(define-public python-3 python-3.7)