summaryrefslogtreecommitdiff
path: root/gnu/packages/python.scm
diff options
context:
space:
mode:
authorMaxime Devos <maximedevos@telenet.be>2021-07-14 13:12:56 +0200
committerMathieu Othacehe <othacehe@gnu.org>2021-07-14 15:57:40 +0200
commitaec20fae9747c541d2ff1512fe52f26428a89c02 (patch)
tree59eb81fee29a9b0c1f19037813f5d9c9c9707554 /gnu/packages/python.scm
parentad7c6d290e58c3c9cb0ca573bf1ef44d124d11ec (diff)
downloadguix-patches-aec20fae9747c541d2ff1512fe52f26428a89c02.tar
guix-patches-aec20fae9747c541d2ff1512fe52f26428a89c02.tar.gz
python: Fix reference to input when cross-compiling.
"sitecustomize.py" is a native input, so look it up in 'native-inputs', not 'inputs'. * gnu/packages/python.scm (customize-site): Look up "sizecustomize.py" in 'native-inputs', not 'inputs'. Signed-off-by: Mathieu Othacehe <othacehe@gnu.org>
Diffstat (limited to 'gnu/packages/python.scm')
-rw-r--r--gnu/packages/python.scm5
1 files changed, 3 insertions, 2 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 227c612a68..ef47e79632 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -110,13 +110,14 @@
(define* (customize-site version)
"Generate a install-sitecustomize.py phase, using VERSION."
- `(lambda* (#:key inputs outputs #:allow-other-keys)
+ `(lambda* (#:key native-inputs inputs outputs #:allow-other-keys)
(let* ((out (assoc-ref outputs "out"))
(site-packages (string-append
out "/lib/python"
,(version-major+minor version)
"/site-packages"))
- (sitecustomize.py (assoc-ref inputs "sitecustomize.py"))
+ (sitecustomize.py (assoc-ref (or native-inputs inputs)
+ "sitecustomize.py"))
(dest (string-append site-packages "/sitecustomize.py")))
(mkdir-p site-packages)
(copy-file sitecustomize.py dest)