summaryrefslogtreecommitdiff
path: root/gnu/packages/python.scm
diff options
context:
space:
mode:
authorKei Kebreau <kkebreau@posteo.net>2019-01-06 00:50:55 -0500
committerKei Kebreau <kkebreau@posteo.net>2019-01-12 16:38:36 -0500
commitacbf312573be8a1f211986169710dd77d460f189 (patch)
tree23e7bd496464ad592b4d2e617263e8c6eaa49970 /gnu/packages/python.scm
parent146c6b62bf72abbe710ce29972a8db17c6285b54 (diff)
downloadguix-patches-acbf312573be8a1f211986169710dd77d460f189.tar
guix-patches-acbf312573be8a1f211986169710dd77d460f189.tar.gz
gnu: python-pillow: Update to 5.4.0
* gnu/packages/python.scm (python-pillow): Update to 5.4.0. [arguments]: Add 'patch-ldconfig' phase.
Diffstat (limited to 'gnu/packages/python.scm')
-rw-r--r--gnu/packages/python.scm33
1 files changed, 18 insertions, 15 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 507cdd3db4..d412ee5077 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -4075,17 +4075,17 @@ the OleFileIO module from PIL, the Python Image Library.")
(define-public python-pillow
(package
(name "python-pillow")
- (version "5.2.0")
+ (version "5.4.0")
(source
(origin
(method url-fetch)
(uri (pypi-uri "Pillow" version))
(sha256
(base32
- "1ary9mj2ddllq3lkxgn6aac7qxqiwbcg2pacrl94py58ql9x9czq"))))
+ "0qrkcjszym7ixffg5zphhp8a07w8w11yyc2ylcbdrhwm771z316m"))))
(build-system python-build-system)
(native-inputs
- `(("python-pytest" ,python-pytest)))
+ `(("python-pytest" ,python-pytest)))
(inputs
`(("freetype" ,freetype)
("lcms" ,lcms)
@@ -4097,18 +4097,21 @@ the OleFileIO module from PIL, the Python Image Library.")
(propagated-inputs
`(("python-olefile" ,python-olefile)))
(arguments
- `(#:phases (modify-phases %standard-phases
- (add-after
- 'install 'check-installed
- (lambda* (#:key outputs inputs #:allow-other-keys)
- (begin
- (setenv "HOME" (getcwd))
- ;; Make installed package available for running the
- ;; tests
- (add-installed-pythonpath inputs outputs)
- (invoke "python" "selftest.py" "--installed")
- (invoke "python" "-m" "pytest" "-vv"))))
- (delete 'check))))
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'patch-ldconfig
+ (lambda _
+ (substitute* "setup.py"
+ (("\\['/sbin/ldconfig', '-p'\\]") "['true']"))))
+ (delete 'check) ; We must run checks after python-pillow is installed.
+ (add-after 'install 'check-installed
+ (lambda* (#:key outputs inputs #:allow-other-keys)
+ (begin
+ (setenv "HOME" (getcwd))
+ ;; Make installed package available for running the tests.
+ (add-installed-pythonpath inputs outputs)
+ (invoke "python" "selftest.py" "--installed")
+ (invoke "python" "-m" "pytest" "-vv")))))))
(home-page "https://pypi.python.org/pypi/Pillow")
(synopsis "Fork of the Python Imaging Library")
(description