summaryrefslogtreecommitdiff
path: root/gnu/packages/python.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2019-05-03 23:46:29 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2019-05-03 23:46:29 -0400
commita5e9413ce874d8e26f78361a91965f6ff9735bf4 (patch)
treec4d2259d92d96a3fdb527952729fe6939b6af2fe /gnu/packages/python.scm
parent123bba720d569e533d45173c472475d655541dae (diff)
downloadguix-patches-a5e9413ce874d8e26f78361a91965f6ff9735bf4.tar
guix-patches-a5e9413ce874d8e26f78361a91965f6ff9735bf4.tar.gz
gnu: python: Disable failing test.
Fixes issue #35556 (see: https://bugs.gnu.org/35556). * gnu/packages/python.scm (python-3.7)[make-flags]: Exclude the test "test_asyncio", which currently fails.
Diffstat (limited to 'gnu/packages/python.scm')
-rw-r--r--gnu/packages/python.scm7
1 files changed, 5 insertions, 2 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 4fd7948327..244e0d1a1b 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -352,8 +352,11 @@ data types.")
(arguments
(substitute-keyword-arguments (package-arguments python-2)
((#:make-flags _)
- ;; Strip tests exclusions that have to do with Python 2 only.
- `(list (format #f "TESTOPTS=-j~d" (parallel-job-count))))
+ `(list (string-append
+ (format #f "TESTOPTS=-j~d" (parallel-job-count))
+ ;; Exclude the following test, which fails as of 3.7.3 (see:
+ ;; https://bugs.python.org/issue35998).
+ " --exclude test_asyncio")))
((#:phases phases)
`(modify-phases ,phases
;; Unset SOURCE_DATE_EPOCH while running the test-suite and set it