summaryrefslogtreecommitdiff
path: root/gnu/packages/python.scm
diff options
context:
space:
mode:
authorMuriithi Frederick Muriuki <fredmanglis@gmail.com>2017-05-28 18:32:38 +0300
committerMarius Bakke <mbakke@fastmail.com>2017-06-04 14:28:58 +0200
commita0ffc701d495c1847d45537488c0d5a19bbcb5b8 (patch)
treeb865e7dc19010e4e5f323bae7488e179362292f4 /gnu/packages/python.scm
parent50d586f6df73ed493b5b04636ac3566782491b90 (diff)
downloadguix-patches-a0ffc701d495c1847d45537488c0d5a19bbcb5b8.tar
guix-patches-a0ffc701d495c1847d45537488c0d5a19bbcb5b8.tar.gz
gnu: Add python2-couleur.
* gnu/packages/python.scm (python2-couleur): New variable. Signed-off-by: Marius Bakke <mbakke@fastmail.com>
Diffstat (limited to 'gnu/packages/python.scm')
-rw-r--r--gnu/packages/python.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 7bad7fd187..e1d9115f31 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -14953,3 +14953,29 @@ Sure is heavily inspired by @code{RSpec Expectations} and @code{should.js}.")
(define-public python2-sure
(package-with-python2 python-sure))
+
+(define-public python2-couleur
+ ;; This package does not seem to support python3 at all, hence,
+ ;; only the python2 variant definition is provided.
+ (package
+ (name "python2-couleur")
+ (version "0.6.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "couleur" version))
+ (sha256
+ (base32
+ "1qqaxyqz74wvid0cr119dhcwz0h0if5b5by44zl49pd5z65v58k1"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:python ,python-2))
+ (home-page "https://github.com/gabrielfalcao/couleur")
+ (synopsis
+ "ANSI terminal tool for python, colored shell and other handy fancy features")
+ (description
+ "@code{Couleur} provides python programs a way to use the ANSI features in a unix
+terminal such as coloured output in the shell, overwriting output, indentation, etc.")
+ ;; README.md says ASL2.0, but all source code headers are LGPL3+.
+ ;; https://github.com/gabrielfalcao/couleur/issues/11
+ (license license:lgpl3+)))