summaryrefslogtreecommitdiff
path: root/gnu/packages/python.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2019-01-02 16:29:51 +0100
committerRicardo Wurmus <rekado@elephly.net>2019-01-02 16:33:57 +0100
commit9fb5771af76123cfecee83da677cb7fb7a6c810c (patch)
tree5f8eedfc6777ad0a74b296826884e9d21af778dc /gnu/packages/python.scm
parentd47b21c69c07bb9e0d0e00ddee278e8dbb8c7c42 (diff)
downloadguix-patches-9fb5771af76123cfecee83da677cb7fb7a6c810c.tar
guix-patches-9fb5771af76123cfecee83da677cb7fb7a6c810c.tar.gz
gnu: jupyter: Add missing dependency.
* gnu/packages/python.scm (jupyter)[propagated-inputs]: Add python-qtconsole. [home-page]: Use https URL. [arguments]: Update comment on why tests are disabled.
Diffstat (limited to 'gnu/packages/python.scm')
-rw-r--r--gnu/packages/python.scm12
1 files changed, 5 insertions, 7 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 8bc2935761..ad5c564278 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -7,7 +7,7 @@
;;; Copyright © 2014, 2015 Federico Beffa <beffa@fbengineering.ch>
;;; Copyright © 2015 Omar Radwan <toxemicsquire4@gmail.com>
;;; Copyright © 2015 Pierre-Antoine Rault <par@rigelk.eu>
-;;; Copyright © 2015, 2016, 2017, 2018 Ricardo Wurmus <rekado@elephly.net>
+;;; Copyright © 2015, 2016, 2017, 2018, 2019 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2015, 2016 Christopher Allan Webber <cwebber@dustycloud.org>
;;; Copyright © 2015 Eric Dvorsak <eric@dvorsak.fr>
;;; Copyright © 2015, 2016 David Thompson <davet@gnu.org>
@@ -7381,21 +7381,19 @@ support for rich media output.")
(base32
"0pwf3pminkzyzgx5kcplvvbvwrrzd3baa7lmh96f647k30rlpp6r"))))
(build-system python-build-system)
- ;; FIXME: it's not clear how to run the tests.
- (arguments `(#:tests? #f))
+ (arguments '(#:tests? #f)) ; there are none.
(propagated-inputs
`(("python-ipykernel" ,python-ipykernel)
("python-ipywidgets" ,python-ipywidgets)
("python-jupyter-console" ,python-jupyter-console)
("python-nbconvert" ,python-nbconvert)
- ("python-notebook" ,python-notebook)))
-
+ ("python-notebook" ,python-notebook)
+ ("python-qtconsole" ,python-qtconsole)))
(native-search-paths
(list (search-path-specification
(variable "JUPYTER_PATH")
(files '("share/jupyter")))))
-
- (home-page "http://jupyter.org")
+ (home-page "https://jupyter.org")
(synopsis "Web application for interactive documents")
(description
"The Jupyter Notebook is a web application that allows you to create and