summaryrefslogtreecommitdiff
path: root/gnu/packages/python.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2019-01-02 16:27:18 +0100
committerRicardo Wurmus <rekado@elephly.net>2019-01-02 16:33:57 +0100
commit91dd8b368703ab0d183839fbe9fa8a3d23bf5001 (patch)
treeca2d0fe2370bb4a4e70357e1b0f54174ad05c0d6 /gnu/packages/python.scm
parent493e5e6daa058b7eb5e2ffbeccad2a5bd47dc60d (diff)
downloadguix-patches-91dd8b368703ab0d183839fbe9fa8a3d23bf5001.tar
guix-patches-91dd8b368703ab0d183839fbe9fa8a3d23bf5001.tar.gz
gnu: python-notebook: Update to 5.7.4.
* gnu/packages/python.scm (python-notebook): Update to 5.7.4. [arguments]: Use INVOKE for tests. [propagated-inputs]: Remove python-ipython; add python-prometheus-client, python-send2trash, and python-terminado.
Diffstat (limited to 'gnu/packages/python.scm')
-rw-r--r--gnu/packages/python.scm19
1 files changed, 14 insertions, 5 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index e15f6f6a8e..f68062a481 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -7157,27 +7157,36 @@ system.")
(define-public python-notebook
(package
(name "python-notebook")
- (version "4.2.3")
+ (version "5.7.4")
(source (origin
(method url-fetch)
(uri (pypi-uri "notebook" version))
(sha256
(base32
- "0laq5c2f21frq6xcdckgq7raqhznbjb0qs0357g612z87wyn1a9r"))))
+ "0jm7324mbxljmn9hgapj66q7swyz5ai92blmr0jpcy0h80x6f26r"))))
(build-system python-build-system)
(arguments
`(#:phases
(modify-phases %standard-phases
(replace 'check
(lambda _
- ;; HOME must be set for tests
+ ;; These tests require a browser
+ (delete-file-recursively "notebook/tests/selenium")
+ ;; Some tests need HOME
(setenv "HOME" "/tmp")
- (zero? (system* "nosetests")))))))
+ ;; This file contains "warningfilters", which are not supported
+ ;; by this version of nose.
+ (delete-file "setup.cfg")
+ (with-directory-excursion "/tmp"
+ (invoke "nosetests" "-v"))
+ #t)))))
(propagated-inputs
`(("python-jupyter-core" ,python-jupyter-core)
("python-nbformat" ,python-nbformat)
("python-nbconvert" ,python-nbconvert)
- ("python-ipython" ,python-ipython)))
+ ("python-prometheus-client" ,python-prometheus-client)
+ ("python-send2trash" ,python-send2trash)
+ ("python-terminado" ,python-terminado)))
(native-inputs
`(("python-nose" ,python-nose)
("python-sphinx" ,python-sphinx)