summaryrefslogtreecommitdiff
path: root/gnu/packages/python.scm
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2021-02-19 18:09:57 -0500
committerLeo Famulari <leo@famulari.name>2021-02-23 14:12:33 -0500
commit84e082e31706411e7f9c3189a83f8ed0b4016fe7 (patch)
tree3c1d8a587c0467d1067386458b7832fe75e88a5b /gnu/packages/python.scm
parentc60ab406308fd3c00922dddc4fbf6e49a78fd8e6 (diff)
downloadguix-patches-84e082e31706411e7f9c3189a83f8ed0b4016fe7.tar
guix-patches-84e082e31706411e7f9c3189a83f8ed0b4016fe7.tar.gz
gnu: Python: Fix CVE-2021-3177.
* gnu/packages/patches/python-3.8-CVE-2021-3177.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it. * gnu/packages/python.scm (python-3.8)[replacement]: New field. (python-3.8/fixed): New variable.
Diffstat (limited to 'gnu/packages/python.scm')
-rw-r--r--gnu/packages/python.scm9
1 files changed, 9 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 730c371fda..5c5be0d78c 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -364,6 +364,7 @@ data types.")
(define-public python-3.8
(package (inherit python-2)
(name "python")
+ (replacement python-3.8/fixed)
(version "3.8.2")
(source (origin
(method url-fetch)
@@ -521,6 +522,14 @@ data types.")
(version-major+minor version)
"/site-packages"))))))))
+(define python-3.8/fixed
+ (package
+ (inherit python-3.8)
+ (source (origin
+ (inherit (package-source python-3.8))
+ (patches (append (search-patches "python-3.8-CVE-2021-3177.patch")
+ (origin-patches (package-source python-3.8))))))))
+
(define-public python-3.9
(package (inherit python-3.8)
(name "python-next")