summaryrefslogtreecommitdiff
path: root/gnu/packages/python.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-01-27 18:08:29 -0500
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-02-01 11:54:01 -0500
commit68676442509a397f5947b18c36452720c36d0793 (patch)
treee679aa1b3274aeaf799b9abceda64e720e4125ad /gnu/packages/python.scm
parent792935c8da70ff7b4d033726d78f106de8f08d4c (diff)
downloadguix-patches-68676442509a397f5947b18c36452720c36d0793.tar
guix-patches-68676442509a397f5947b18c36452720c36d0793.tar.gz
gnu: pypy3: Do not alter PYTHONPATH.
* gnu/packages/python.scm (pypy3): Do not alter PYTHONPATH.
Diffstat (limited to 'gnu/packages/python.scm')
-rw-r--r--gnu/packages/python.scm3
1 files changed, 0 insertions, 3 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 258e0749f0..8e8f46467b 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -775,9 +775,6 @@ ease from the desktop to a microcontroller or embedded system.")
"targetpypystandalone"))
;; Build c modules and package everything, so tests work.
(with-directory-excursion "pypy/tool/release"
- (unsetenv "PYTHONPATH") ; Do not use the system’s python libs:
- ; AttributeError: module 'enum' has no
- ; attribute 'IntFlag'
(invoke "python2" "package.py"
"--archive-name" "pypy-dist"
"--builddir" (getcwd)))))