summaryrefslogtreecommitdiff
path: root/gnu/packages/python.scm
diff options
context:
space:
mode:
authorMuriithi Frederick Muriuki <fredmanglis@gmail.com>2017-05-28 18:32:40 +0300
committerMarius Bakke <mbakke@fastmail.com>2017-06-04 14:42:29 +0200
commit5786b47c7ef8a21592281fa60adaf95bb0041be1 (patch)
tree4fb2cf73e0bbd144ff795941e479838228566b2c /gnu/packages/python.scm
parent511b47dec2fbe16473a2c6abb0cc6627b4b2d94e (diff)
downloadguix-patches-5786b47c7ef8a21592281fa60adaf95bb0041be1.tar
guix-patches-5786b47c7ef8a21592281fa60adaf95bb0041be1.tar.gz
gnu: Add python2-steadymark.
* gnu/packages/python.scm (python2-steadymark): New variable. Signed-off-by: Marius Bakke <mbakke@fastmail.com>
Diffstat (limited to 'gnu/packages/python.scm')
-rw-r--r--gnu/packages/python.scm39
1 files changed, 39 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index e2163f3948..ee216116cc 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -15011,3 +15011,42 @@ renderers (e.g. man pages or LaTeX).")
(define-public python2-misaka
(package-with-python2 python-misaka))
+
+(define-public python2-steadymark
+ ;; This is forced into being a python2 only variant
+ ;; due to its dependence on couleur that has no support
+ ;; for python3
+ (package
+ (name "python2-steadymark")
+ (version "0.7.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "steadymark" version))
+ (sha256
+ (base32
+ "1640i9g8dycql3cc8j0bky0jkzj0q39blfbp4lsgpkprkfgcdk8v"))))
+ (build-system python-build-system)
+ (native-inputs
+ `(("python-couleur" ,python2-couleur)
+ ("python-sure" ,python2-sure)
+ ("python-misaka" ,python2-misaka)))
+ (arguments
+ `(#:python ,python-2
+ #:phases
+ (modify-phases %standard-phases
+ (add-before 'build 'patch-setup-py
+ (lambda _
+ ;; Update requirements from dependency==version
+ ;; to dependency>=version
+ (substitute* "setup.py"
+ (("==") ">="))
+ #t)))))
+ (home-page "https://github.com/gabrielfalcao/steadymark")
+ (synopsis "Markdown-based test runner for python")
+ (description
+ "@code{Steadymark} allows documentation to be written in github-flavoured
+markdown. The documentation may contain snippets of code surrounded by python
+code blocks and @code{Steadymark} will find these snippets and run them, making
+sure that there are no old malfunctional examples in the documentation examples.")
+ (license license:expat)))