summaryrefslogtreecommitdiff
path: root/gnu/packages/python.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-08-04 14:54:09 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-08-05 10:29:58 -0400
commit49432f6534c900e90017726f08cb37397662a9b8 (patch)
tree0e2f7c9c7a210e21242f90d9d6b7a4ab5337a831 /gnu/packages/python.scm
parentead6cc03c66ed31f0ab7300fab11cef3a1e459f0 (diff)
downloadguix-patches-49432f6534c900e90017726f08cb37397662a9b8.tar
guix-patches-49432f6534c900e90017726f08cb37397662a9b8.tar.gz
gnu: pypy3: Update to 7.3.5.
The patch disabling tests is removed because it only fixes 2 out of 43 test failures. * gnu/packages/patches/pypy3-7.3.1-fix-tests.patch: Delete file. * gnu/local.mk (dist_patch_DATA): De-register it. * gnu/packages/python.scm (pypy3): Update to 7.3.5. [patches]: Remove patch.
Diffstat (limited to 'gnu/packages/python.scm')
-rw-r--r--gnu/packages/python.scm11
1 files changed, 5 insertions, 6 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index e694321e17..5cc02d5ba3 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -716,15 +716,14 @@ ease from the desktop to a microcontroller or embedded system.")
(define-public pypy3
(package
(name "pypy3")
- (version "7.3.1")
+ (version "7.3.5")
(source (origin
(method url-fetch)
- (uri (string-append "https://bitbucket.org/pypy/pypy/downloads/" ;
- "pypy3.6-v" version "-src.tar.bz2"))
+ (uri (string-append "https://downloads.python.org/pypy/"
+ "pypy3.7-v" version "-src.tar.bz2"))
(sha256
(base32
- "10zsk8jby8j6visk5mzikpb1cidvz27qq4pfpa26jv53klic6b0c"))
- (patches (search-patches "pypy3-7.3.1-fix-tests.patch"))))
+ "18lrdmpcczlbk3cfarkgwqdmilrybz56i1dafk8dkjlyk90gw86r"))))
(build-system gnu-build-system)
(native-inputs
`(("python-2" ,python-2)
@@ -749,7 +748,7 @@ ease from the desktop to a microcontroller or embedded system.")
("bash-minimal" ,bash-minimal) ; Used as /bin/sh
("xz" ,xz))) ; liblzma
(arguments
- `(#:tests? #f ;FIXME: Disabled for now, there are many tests failing.
+ `(#:tests? #f ;FIXME: 43 out of 364 tests are failing
#:modules ((ice-9 ftw) (ice-9 match)
(guix build utils) (guix build gnu-build-system))
#:phases (modify-phases %standard-phases