summaryrefslogtreecommitdiff
path: root/gnu/packages/python.scm
diff options
context:
space:
mode:
authorGreg Hogan <code@greghogan.com>2021-02-24 14:12:28 +0000
committerLeo Famulari <leo@famulari.name>2021-02-25 14:41:41 -0500
commit10b909a0249fd53d589890b357232db4165690f5 (patch)
treece9c57f86abee1b7b3082f6f39b19c1251e56776 /gnu/packages/python.scm
parentf16168744e8d5ab30cc77919cc06389c3f4a6abe (diff)
downloadguix-patches-10b909a0249fd53d589890b357232db4165690f5.tar
guix-patches-10b909a0249fd53d589890b357232db4165690f5.tar.gz
gnu: Python 3.9: Update to 3.9.2.
* gnu/packages/python.scm (python-3.9): Update to 3.9.2. [source]: Remove obsolete patch. * gnu/packages/patches/python-3.9-CVE-2021-3177.patch: Delete file. * gnu/local.mk (dist_patch_DATA): Remove it. Signed-off-by: Leo Famulari <leo@famulari.name>
Diffstat (limited to 'gnu/packages/python.scm')
-rw-r--r--gnu/packages/python.scm6
1 files changed, 3 insertions, 3 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 5c5be0d78c..9d97050c66 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -59,6 +59,7 @@
;;; Copyright © 2018 Vagrant Cascadian <vagrant@debian.org>
;;; Copyright © 2019 Tanguy Le Carrour <tanguy@bioneland.org>
;;; Copyright © 2020 Jan (janneke) Nieuwenhuizen <janneke@gnu.org>
+;;; Copyright © 2021 Greg Hogan <code@greghogan.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -533,19 +534,18 @@ data types.")
(define-public python-3.9
(package (inherit python-3.8)
(name "python-next")
- (version "3.9.1")
+ (version "3.9.2")
(source (origin
(method url-fetch)
(uri (string-append "https://www.python.org/ftp/python/"
version "/Python-" version ".tar.xz"))
(patches (search-patches
"python-3.9-fix-tests.patch"
- "python-3.9-CVE-2021-3177.patch"
"python-3-deterministic-build-info.patch"
"python-3-search-paths.patch"))
(sha256
(base32
- "1zq3k4ymify5ig739zyvx9s2ainvchxb1zpy139z74krr653y74r"))
+ "0z94vv5qhlwvcgc4sy9sdiqs0220s84wx3b62vslh5419z2k881w"))
(modules '((guix build utils)))
(snippet
'(begin