summaryrefslogtreecommitdiff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
authorMădălin Ionel Patrașcu <madalinionel.patrascu@mdc-berlin.de>2019-12-17 18:24:34 +0100
committerRicardo Wurmus <rekado@elephly.net>2019-12-19 00:01:49 +0100
commitfcc4e9e7f7cb63b93f953038bc5f57039af69971 (patch)
treed9bfad86c3cb583a4515fab993a87ad6b2ce265b /gnu/packages/python-xyz.scm
parent32be357706c0667af2003fa875f06ef18957669d (diff)
downloadguix-patches-fcc4e9e7f7cb63b93f953038bc5f57039af69971.tar
guix-patches-fcc4e9e7f7cb63b93f953038bc5f57039af69971.tar.gz
gnu: python-multiprocess: Update to 0.70.9.
* gnu/packages/python-xyz.scm (python-multiprocess): Update to 0.70.9. [arguments]: Add phase "disable-broken-tests" and run tests after installation. Co-authored-by: Ricardo Wurmus <rekado@elephly.net>.
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm26
1 files changed, 23 insertions, 3 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 9075dfeb49..1718758721 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -15685,18 +15685,38 @@ the saved state of the original interpreter session.")
(define-public python-multiprocess
(package
(name "python-multiprocess")
- (version "0.70.6.1")
+ (version "0.70.9")
(source
(origin
(method url-fetch)
(uri (pypi-uri "multiprocess" version))
(sha256
(base32
- "1ip5caz67b3q0553mr8gm8xwsb8x500jn8ml0gihgyfy52m2ypcq"))))
+ "1r882nvd44xqwbrclwqx5rhs80l6809rcvpc7pkpgnij06cvvmcz"))))
(build-system python-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'disable-broken-tests
+ (lambda _
+ ;; This test is broken as there is no keyboard interrupt.
+ (substitute* "py3.7/multiprocess/tests/__init__.py"
+ (("^(.*)def test_wait_result"
+ line indent)
+ (string-append indent
+ "@unittest.skip(\"Disabled by Guix\")\n"
+ line)))
+ #t))
+ ;; Tests must be run after installation.
+ (delete 'check)
+ (add-after 'install 'check
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (add-installed-pythonpath inputs outputs)
+ (invoke "python" "-m" "multiprocess.tests")
+ #t)))))
(propagated-inputs
`(("python-dill" ,python-dill)))
- (home-page "https://pypi.org/project/multiprocess")
+ (home-page "https://pypi.org/project/multiprocess/")
(synopsis "Multiprocessing and multithreading in Python")
(description
"This package is a fork of the multiprocessing Python package, a package