summaryrefslogtreecommitdiff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
authorLars-Dominik Braun <lars@6xq.net>2021-04-20 09:50:12 +0200
committerLars-Dominik Braun <lars@6xq.net>2021-04-26 10:26:47 +0200
commitf371e53aaaf436b140fe5da3bd40a2b04b10bf51 (patch)
treead2c3605fe8c1971e56e84eac49c572f2b896915 /gnu/packages/python-xyz.scm
parenta0e98da14f318f02b008b71d6bf236171dff67e3 (diff)
downloadguix-patches-f371e53aaaf436b140fe5da3bd40a2b04b10bf51.tar
guix-patches-f371e53aaaf436b140fe5da3bd40a2b04b10bf51.tar.gz
gnu: Add python-ipykernel-bootstrap.
* gnu/packages/python-xyz.scm (python-ipykernel-bootstrap): New variable.
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm13
1 files changed, 13 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index fcd8b2d76f..8c632947ea 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -7529,6 +7529,19 @@ installing @code{kernelspec}s for use with Jupyter frontends.")
"This package provides the IPython kernel for Jupyter.")
(license license:bsd-3)))
+;; Bootstrap variant of ipykernel, which uses the bootstrap jupyter-client to
+;; break the cycle between ipykernel and jupyter-client.
+(define-public python-ipykernel-bootstrap
+ (let ((parent python-ipykernel))
+ (hidden-package
+ (package
+ (inherit parent)
+ (name "python-ipykernel-bootstrap")
+ (propagated-inputs
+ `(("python-jupyter-client" ,python-jupyter-client-bootstrap)
+ ,@(fold alist-delete (package-propagated-inputs parent)
+ '("python-jupyter-client"))))))))
+
(define-public python-pari-jupyter
(package
(name "python-pari-jupyter")