summaryrefslogtreecommitdiff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
authorRaghav Gururajan <rg@raghavgururajan.name>2021-06-28 17:40:04 -0400
committerRaghav Gururajan <rg@raghavgururajan.name>2021-06-28 17:43:24 -0400
commite61874a5983c4fcb39b33248d044f22257e2f189 (patch)
tree2410c9498d79dae082bc1686c2c2aafdab71f75e /gnu/packages/python-xyz.scm
parent3fdb2d679259f5d1541240dd4e9cedda17040bf2 (diff)
downloadguix-patches-e61874a5983c4fcb39b33248d044f22257e2f189.tar
guix-patches-e61874a5983c4fcb39b33248d044f22257e2f189.tar.gz
gnu: python-fire: Respect #:tests?
* gnu/packages/python-xyz.scm (python-fire)[arguments]: Respect #:tests? in the custom 'check' phase.
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm4
1 files changed, 3 insertions, 1 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 41761d8b7a..f0fbe91b73 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -276,7 +276,9 @@ workspaces.
'(#:phases
(modify-phases %standard-phases
(replace 'check
- (lambda _ (invoke "pytest"))))))
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ (invoke "pytest")))))))
(inputs
`(("python-six", python-six)
("python-termcolor", python-termcolor)))