summaryrefslogtreecommitdiff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2021-05-23 14:07:34 +0200
committerMarius Bakke <marius@gnu.org>2021-05-23 17:49:56 +0200
commitdbcf2b61b1f48cbe84d51873f4e4de60897b914c (patch)
tree92dc5d19b2899a91d22a53fb1a6e6f3ffedd8d2c /gnu/packages/python-xyz.scm
parent9351b2a48145a690484ff38ace0ccb828c204c09 (diff)
downloadguix-patches-dbcf2b61b1f48cbe84d51873f4e4de60897b914c.tar
guix-patches-dbcf2b61b1f48cbe84d51873f4e4de60897b914c.tar.gz
gnu: Fix erroneous uses of 'package/inherit'.
These packages use a different source/version from the inherited package, and thus should not inherit replacements. * gnu/packages/check.scm (googletest-1.8, python-pytest-runner-2): Use record inheritance instead of PACKAGE/INHERIT. * gnu/packages/crates-io.scm (rust-bindgen-0.49, rust-bytes-0.4, rust-colored-1.9.1, rust-difference-1, rust-docopt-0.8, rust-html5ever-0.23, rust-http-0.1, rust-http-body-0.1, rust-loom-0.2, rust-loom-0.1, rust-pulldown-cmark-0.0.8, rust-ring-0.13, rust-rustls-0.12, rust-sct-0.3, rust-term-0.2, rust-untrusted-0.6, rust-webpki-0.18, rust-webpki-roots-0.17, rust-webpki-roots-0.14): Likewise. * gnu/packages/emacs.scm (emacs-next, emacs-next-pgtk, guile-emacs): Likewise. * gnu/packages/guile.scm (guile-2.2.4): Likewise. * gnu/packages/maths.scm (hdf5-1.10, hdf5-1.12): Likewise. * gnu/packages/protobuf.scm (protobuf-3.6, protobuf-3.5, python-protobuf-3.6): Likewise. * gnu/packages/python-web.scm (python2-html2text): Likewise. * gnu/packages/python-xyz.scm (python-pygments/fixed, python2-numpy, python2-urwid, python2-markdown, python2-fonttools): Likewise. * gnu/packages/racket.scm (racket): Likewise. * gnu/packages/sequoia.scm (sequoia4pEp): Likewise.
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm18
1 files changed, 10 insertions, 8 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index c501b65a55..5a3c6b670e 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -3980,7 +3980,8 @@ text styles of documentation.")
(properties `((python2-variant . ,(delay python2-pygments))))))
(define python-pygments/fixed
- (package/inherit python-pygments
+ (package
+ (inherit python-pygments)
(version "2.7.4")
(source
(origin
@@ -4969,8 +4970,8 @@ capabilities.")
(define-public python2-numpy
(let ((numpy (package-with-python2
(strip-python2-variant python-numpy))))
- (package/inherit
- numpy
+ (package
+ (inherit numpy)
(version "1.16.5")
(source (origin
(method url-fetch)
@@ -8087,7 +8088,8 @@ features useful for text console applications.")
(define-public python2-urwid
(let ((base (package-with-python2
(strip-python2-variant python-urwid))))
- (package/inherit base
+ (package
+ (inherit base)
(version "2.1.0")
(source
(origin
@@ -9528,8 +9530,8 @@ markdown_py is also provided to convert Markdown files to HTML.")
;; Markdown 3.2 dropped support for Python 2.
(define-public python2-markdown
(let ((base (package-with-python2 (strip-python2-variant python-markdown))))
- (package/inherit
- base
+ (package
+ (inherit base)
(version "3.1.1")
(source (origin
(method url-fetch)
@@ -9697,8 +9699,8 @@ from an XML-based format.")
;; Fonttools 4.x dropped support for Python 2, so stick with 3.x here.
(define-public python2-fonttools
(let ((base (package-with-python2 (strip-python2-variant python-fonttools))))
- (package/inherit
- base
+ (package
+ (inherit base)
(version "3.44.0")
(source (origin
(method url-fetch)