summaryrefslogtreecommitdiff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-08-15 08:26:08 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-08-15 08:30:14 -0400
commitd8537c68d09daaa3e8db35022ac45b5f2fe8ffda (patch)
tree37f8bb2ea6c09d124eb70bae625557f33c9ce59a /gnu/packages/python-xyz.scm
parent21f1a47097f61764463289f8d305a8f860f0f224 (diff)
downloadguix-patches-d8537c68d09daaa3e8db35022ac45b5f2fe8ffda.tar
guix-patches-d8537c68d09daaa3e8db35022ac45b5f2fe8ffda.tar.gz
gnu: Add python-robotframework-sshtunnellibrary.
* gnu/packages/python-xyz.scm (python-robotframework-sshtunnellibrary): New variable.
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 9ab75507e5..95507971b2 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -4898,6 +4898,35 @@ utility, a static analysis tool (linter) for Robot Framework source files.")
tunnels in the background, using Python.")
(license license:expat)))
+(define-public python-robotframework-sshtunnellibrary
+ (package
+ (name "python-robotframework-sshtunnellibrary")
+ (version "1.0.0")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/C-Squad/robotframework-sshtunnellibrary")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1vkkmkb8iql13xpbyj4hvnnmfgzqlr8rffgryp2082cadb3w7xrd"))))
+ (build-system python-build-system)
+ (arguments
+ (list #:phases #~(modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ (invoke "python" "-m" "unittest"
+ "discover" "-s" "test")))))))
+ (propagated-inputs (list python-robotframework python-sshtunnel))
+ (home-page "https://github.com/C-Squad/robotframework-sshtunnellibrary")
+ (synopsis "Alternative RobotFramework library for SSH tunnels")
+ (description "SSHTunnelLibrary is an alternative RobotFramework
+library (to the more official one that comes from the
+@code{robotframework-sshlibrary} package) to support SSH tunnels.")
+ (license license:asl2.0)))
+
(define-public python-robotframework-stacktrace
(package
(name "python-robotframework-stacktrace")