summaryrefslogtreecommitdiff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2020-04-09 00:53:28 +0200
committerMarius Bakke <mbakke@fastmail.com>2020-04-09 00:53:28 +0200
commitd523eb5c9c2659cbbaf4eeef3691234ae527ee6a (patch)
tree82854d10fb0cad6f5b6a3e0027bc3690d44e9384 /gnu/packages/python-xyz.scm
parentc7eec67a93d58b2c0201f98071407f5a0cf549a7 (diff)
downloadguix-patches-d523eb5c9c2659cbbaf4eeef3691234ae527ee6a.tar
guix-patches-d523eb5c9c2659cbbaf4eeef3691234ae527ee6a.tar.gz
gnu: python-cython: The i686 python2 workaround is needed for 32-bit ARM too.
* gnu/packages/python-xyz.scm (python-cython)[arguments]: In the check phase, disable parallel test execution for all 32-bit systems. * gnu/packages/python-xyz.scm (python2-cython)[arguments]: Remove similar i686 workaround.
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm20
1 files changed, 7 insertions, 13 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 5e56a2b29c..b26399c646 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -3894,7 +3894,13 @@ provides additional functionality on the produced Mallard documents.")
(setenv "CFLAGS" "-O0")
(invoke "python" "runtests.py" "-vv"
- "-j" (number->string (parallel-job-count))))))))
+ "-j" (number->string (parallel-job-count))
+ ;; XXX: On 32-bit architectures, running the parallel tests
+ ;; fails on many-core systems, see
+ ;; <https://github.com/cython/cython/issues/2807>.
+ ,@(if (not (target-64bit?))
+ '("-x" "run.parallel")
+ '())))))))
(home-page "https://cython.org/")
(synopsis "C extensions for Python")
(description "Cython is an optimising static compiler for both the Python
@@ -3914,18 +3920,6 @@ writing C extensions for Python as easy as Python itself.")
(substitute-keyword-arguments (package-arguments base)
((#:phases phases)
`(modify-phases ,phases
- ;; XXX: On i686-linux, running the parallel tests fails on many-core
- ;; systems, see <https://github.com/cython/cython/issues/2807>.
- ;; TODO: Move this logic to the regular check phase in a future
- ;; rebuild cycle.
- ,@(if (string-prefix? "i686" (%current-system))
- '((replace 'check
- (lambda _
- (setenv "CFLAGS" "-O0")
- (invoke "python" "runtests.py" "-vv"
- "-j" (number->string (parallel-job-count))
- "-x" "run.parallel"))))
- '())
(add-before 'check 'adjust-test_embed
(lambda _
(substitute* "runtests.py"