summaryrefslogtreecommitdiff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2021-05-22 19:46:02 +0200
committerMarius Bakke <marius@gnu.org>2021-05-22 19:53:17 +0200
commitd51b8ac9474a09b3baea4aa8cb1745d6ce9121cd (patch)
tree70283e61552ff1561bf27a093e4f39e696de93f2 /gnu/packages/python-xyz.scm
parent35bd94a49257bbadcb3ca25342e5c1ec33f438f0 (diff)
downloadguix-patches-d51b8ac9474a09b3baea4aa8cb1745d6ce9121cd.tar
guix-patches-d51b8ac9474a09b3baea4aa8cb1745d6ce9121cd.tar.gz
gnu: Remove python2-notebook.
Some of its requirements no longer support Python 2 which has left this package broken for a while. * gnu/packages/python-xyz.scm (python2-notebook): Remove variable. (python-notebook)[properties]: Remove.
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm21
1 files changed, 0 insertions, 21 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index bd716f3dac..2b02efa0c4 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -11200,29 +11200,8 @@ convert an @code{.ipynb} notebook file into various static formats including:
(description
"The Jupyter HTML notebook is a web-based notebook environment for
interactive computing.")
- (properties `((python2-variant . ,(delay python2-notebook))))
(license license:bsd-3)))
-(define-public python2-notebook
- (let ((base (package-with-python2
- (strip-python2-variant python-notebook))))
- (package/inherit base
- (native-inputs
- `(("python2-mock" ,python2-mock)
- ,@(package-native-inputs base)))
- (arguments
- (substitute-keyword-arguments (package-arguments base)
- ((#:phases phases)
- `(modify-phases ,phases
- (add-before 'check 'disable-test-case
- ;; The test requires network access to localhost. Curiously it
- ;; fails with Python 2 only. Simply make the test-case return
- ;; immediately.
- (lambda _
- (substitute*
- "notebook/services/nbconvert/tests/test_nbconvert_api.py"
- (("formats = self.nbconvert_api") "return #")))))))))))
-
(define-public python-widgetsnbextension
(package
(name "python-widgetsnbextension")