summaryrefslogtreecommitdiff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2022-07-24 13:29:31 +0200
committerHartmut Goebel <h.goebel@crazy-compilers.com>2022-08-10 10:02:53 +0200
commitcf2327ecc0e92ec28e8863bb35ff38d9ffaa0615 (patch)
treeff7f294feff521cf8737b38cdf9f31658ecb2e3b /gnu/packages/python-xyz.scm
parentfeef09b28ce802465d4e048e06cd52d57b5fd9f3 (diff)
downloadguix-patches-cf2327ecc0e92ec28e8863bb35ff38d9ffaa0615.tar
guix-patches-cf2327ecc0e92ec28e8863bb35ff38d9ffaa0615.tar.gz
gnu: Add python-cyclic.
* gnu/packages/python-xyz.scm (python-cyclic): New variable.
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 808ca1c8db..1e4d04e069 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -30379,3 +30379,26 @@ window managers.")
"Script for Sway and i3 to automatically switch the horizontal/vertical
window split orientation.")
(license license:gpl3)))
+
+(define-public python-cyclic
+ (package
+ (name "python-cyclic")
+ (version "1.0.0")
+ (source (origin
+ ;; Use git, as there are some test files missing from the PyPI
+ ;; release, see https://github.com/neurobin/cyclic/issues/1
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/neurobin/cyclic")
+ ;; Release is not tagged on github, see
+ ;; https://github.com/neurobin/cyclic/issues/2
+ (commit "bf616c47ea49a43500ea55a1e6f4890323be0679")))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0r8zzjdv70fpxssxps62rlgpii8fr9gh8gykdygqn6mkdnfjwgjc"))))
+ (build-system python-build-system)
+ (home-page "https://github.com/neurobin/cyclic")
+ (synopsis "Handle cyclic relations")
+ (description "This package handles cyclic relations compared by value.")
+ (license license:bsd-3)))