summaryrefslogtreecommitdiff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
authorPierre-Henry Fröhring <contact@phfrohring.com>2022-02-06 09:16:05 +0100
committerLudovic Courtès <ludo@gnu.org>2022-02-27 23:10:24 +0100
commitc88c267f44d361d29ef3dd1fa3c2ee8f04a6baa7 (patch)
tree7eb316babb6a20a63c71e0dc44d49e31682c6163 /gnu/packages/python-xyz.scm
parent38cba91bbcb30796a2a7df1d74ab41933b696eda (diff)
downloadguix-patches-c88c267f44d361d29ef3dd1fa3c2ee8f04a6baa7.tar
guix-patches-c88c267f44d361d29ef3dd1fa3c2ee8f04a6baa7.tar.gz
gnu: Add python-types-ujson.
* gnu/packages/python-xyz.scm (python-types-ujson): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm19
1 files changed, 19 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 96448fc29b..c05502388e 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -29015,3 +29015,22 @@ static types.")
(description "This package provides Python 3 bindings for libfuse 3 with
async I/O support.")
(license license:gpl2+)))
+
+(define-public python-types-ujson
+ (package
+ (name "python-types-ujson")
+ (version "4.2.1")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "types-ujson" version))
+ (sha256
+ (base32
+ "0k9n9hsq4k2zaakdwbkcsvi7m8d3mv2y9yl6f171y58ld4qpcxcy"))))
+ (build-system python-build-system)
+ (home-page "https://github.com/python/typeshed")
+ (synopsis "Typing stubs for ujson")
+ (description
+ "This is a PEP 561 type stub package for the ujson package. It can be
+used by type-checking tools like mypy, PyCharm, pytype etc. to check code that
+uses ujson.")
+ (license license:asl2.0)))