summaryrefslogtreecommitdiff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2021-03-02 18:08:27 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2021-03-02 18:31:42 +0100
commitc48c69194fee468d2ac16ccc25f012312083bf89 (patch)
tree2141d4b4b29dfdbee038fc4154fcfad662fc1ac7 /gnu/packages/python-xyz.scm
parent8c5cafab4978514214aa899ff222597634d58074 (diff)
downloadguix-patches-c48c69194fee468d2ac16ccc25f012312083bf89.tar
guix-patches-c48c69194fee468d2ac16ccc25f012312083bf89.tar.gz
gnu: python-matplotlib: Fix running under Wayland with GTK3.
* gnu/packages/python-xyz.scm (python-matplotlib)[source]: Add patch. * gnu/packages/patches/python-matplotlib-run-under-wayland-gtk3.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it.
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm5
1 files changed, 3 insertions, 2 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 01f1e66258..456cfea5c6 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -5131,8 +5131,9 @@ convert between colorspaces like sRGB, XYZ, CIEL*a*b*, CIECAM02, CAM02-UCS, etc.
(method url-fetch)
(uri (pypi-uri "matplotlib" version))
(sha256
- (base32
- "1nmshfqh7wyg15i16hx1yiylcvzkws29ivn66n3i0wyqwcpjr3lf"))))
+ (base32 "1nmshfqh7wyg15i16hx1yiylcvzkws29ivn66n3i0wyqwcpjr3lf"))
+ (patches
+ (search-patches "python-matplotlib-run-under-wayland-gtk3.patch"))))
(build-system python-build-system)
(propagated-inputs ; the following packages are all needed at run time
`(("python-cycler" ,python-cycler)