summaryrefslogtreecommitdiff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
authorVinicius Monego <monego@posteo.net>2021-04-25 03:25:59 +0000
committerLeo Famulari <leo@famulari.name>2021-04-25 14:49:56 -0400
commitc0fa0efe8a42db051ff42ec014141a6e2a359af6 (patch)
tree075b91a19aee4a2d5a20fc39739827e14cb74951 /gnu/packages/python-xyz.scm
parent862a88612f903ffe5cca1213ba40010876d19c62 (diff)
downloadguix-patches-c0fa0efe8a42db051ff42ec014141a6e2a359af6.tar
guix-patches-c0fa0efe8a42db051ff42ec014141a6e2a359af6.tar.gz
gnu: Add python-anyqt.
* gnu/packages/python-xyz.scm (python-anyqt): New variable. Signed-off-by: Leo Famulari <leo@famulari.name>
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 8e5e06dc01..2ebc512670 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -12555,6 +12555,32 @@ ISO 8859, etc.).")
(define-public python2-translitcodec
(package-with-python2 python-translitcodec))
+(define-public python-anyqt
+ (package
+ (name "python-anyqt")
+ (version "0.0.11")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "AnyQt" version))
+ (sha256
+ (base32 "0gl2czirzjvhbq963i2awxp8kwbc1grh67lpcwfipyn9w3kdwdj4"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:tests? #f ;there are no tests
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'delete-files
+ ;; Delete files related to other operating systems.
+ (lambda _
+ (delete-file "AnyQt/QtMacExtras.py")
+ (delete-file "AnyQt/QtWinExtras.py")
+ #t)))))
+ (home-page "https://github.com/ales-erjavec/anyqt")
+ (synopsis "PyQt4/PyQt5 compatibility layer")
+ (description "AnyQt is a PyQt4/PyQt5 compatibility layer.")
+ (license license:gpl3)))
+
(define-public python-editor
(package
(name "python-editor")