summaryrefslogtreecommitdiff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2020-04-17 00:51:48 +0200
committerMarius Bakke <mbakke@fastmail.com>2020-04-17 00:51:48 +0200
commitbff70d93d22b049c0c4ea3bd234d39f05f794b28 (patch)
treea49658584baab9c46846a4bbf0d4ef6d81165c74 /gnu/packages/python-xyz.scm
parent91fb989f105691a3c0b713c710bd9b27d4def4fc (diff)
downloadguix-patches-bff70d93d22b049c0c4ea3bd234d39f05f794b28.tar
guix-patches-bff70d93d22b049c0c4ea3bd234d39f05f794b28.tar.gz
gnu: python-jedi: Fix test failure on some file systems.
Reported by sirgazil on #guix. * gnu/packages/patches/python-jedi-sort-project-test.patch: New file. * gnu/local.mk (dist_patch_DATA): Adjust accordingly. * gnu/packages/python-xyz.scm (python-jedi)[source](patches): Add it. [arguments]: Run tests more verbosely while at it.
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm3
1 files changed, 2 insertions, 1 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index e3ec0010ce..2c54bfc417 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -11898,6 +11898,7 @@ characters, mouse support, and auto suggestions.")
(origin
(method url-fetch)
(uri (pypi-uri "jedi" version))
+ (patches (search-patches "python-jedi-sort-project-test.patch"))
(sha256
(base32
"0c1h9x3a9klvk2g288wl328x8xgzw7136k6vs9hkd56b85vcjh6z"))))
@@ -11908,7 +11909,7 @@ characters, mouse support, and auto suggestions.")
(replace 'check
(lambda _
(setenv "HOME" "/tmp")
- (invoke "python" "-m" "pytest"))))))
+ (invoke "python" "-m" "pytest" "-vv"))))))
(native-inputs
`(("python-pytest" ,python-pytest)
("python-docopt" ,python-docopt)))