summaryrefslogtreecommitdiff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
authorRoel Janssen <roel@gnu.org>2021-05-28 10:09:10 +0200
committerRoel Janssen <roel@gnu.org>2021-05-28 10:09:10 +0200
commitbb5a3e91e93830622026084af909aabe53693d25 (patch)
tree4d0612f80bd50d53185e0c2152ebde420e30b8cd /gnu/packages/python-xyz.scm
parent87c9f63fce05063c190e277a8d79803fa3693e11 (diff)
downloadguix-patches-bb5a3e91e93830622026084af909aabe53693d25.tar
guix-patches-bb5a3e91e93830622026084af909aabe53693d25.tar.gz
gnu: Add python-argopt.
* gnu/packages/python-xyz.scm (python-argopt): New variable.
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 3540d8fb05..c4f19b4c6f 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -219,6 +219,31 @@
#:use-module (srfi srfi-1)
#:use-module (srfi srfi-26))
+(define-public python-argopt
+ (package
+ (name "python-argopt")
+ (version "0.7.0")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "argopt" version))
+ (sha256
+ (base32
+ "0ybs7kkp0cpl8zn1lvf7481xhssg1bbhh5la2cjzdm5yibashyxa"))))
+ (build-system python-build-system)
+ (native-inputs
+ `(("python-coverage" ,python-coverage)
+ ("python-nose" ,python-nose)
+ ("python-setuptools" ,python-setuptools) ; Won't build without this.
+ ("python-setuptools-scm" ,python-setuptools-scm)))
+ (propagated-inputs
+ `(("python-toml" ,python-toml)
+ ("python-flake8" ,python-flake8)))
+ (home-page "https://github.com/casperdcl/argopt")
+ (synopsis "Generate a command-line interface from a docstring")
+ (description "This package provides tools to define a command line interface
+from a docstring rather than the other way around.")
+ (license license:mpl2.0)))
+
(define-public python-colorful
(package
(name "python-colorful")