summaryrefslogtreecommitdiff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
authorGiacomo Leidi <goodoldpaul@autistici.org>2020-12-28 22:32:41 +0100
committerEfraim Flashner <efraim@flashner.co.il>2021-04-01 15:14:29 +0300
commitb8ebe6dee815ad5611707c29d9ffed50595fdb55 (patch)
tree9d6838ddd8ed8405eb497ad6b16720ef411bf5cb /gnu/packages/python-xyz.scm
parent536fa1bd236f958fdbdb518cd406d28493755538 (diff)
downloadguix-patches-b8ebe6dee815ad5611707c29d9ffed50595fdb55.tar
guix-patches-b8ebe6dee815ad5611707c29d9ffed50595fdb55.tar.gz
gnu: Add python-flake8-continuation.
* gnu/packages/python-xyz.scm (python-flake8-continuation): New variable. Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index bcf5d05b20..e24a9410f0 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -8735,6 +8735,34 @@ design problems in your program. It contains warnings that don't belong
in pyflakes and pycodestyle.")
(license license:expat)))
+(define-public python-flake8-continuation
+ (package
+ (name "python-flake8-continuation")
+ (version "1.0.5")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "flake8-continuation" version))
+ (sha256
+ (base32
+ "0dzaw8jr7yhlabxhrblnrizxx17xa9ngjnbr1kidg5lapq6b9q1y"))))
+ (build-system python-build-system)
+ (propagated-inputs
+ `(("python-flake8" ,python-flake8)
+ ("python-pycodestyle" ,python-pycodestyle)
+ ("python-six" ,python-six)))
+ (home-page "https://github.com/planetlabs/flake8-continuation")
+ (synopsis "Flake8 Line Continuation Plugin")
+ (description "A Flake8 plugin that checks for the line continuation
+style to be in the preferred method according to PEP-8, specifically:
+@quotation
+The preferred way of wrapping long lines is by using Python's implied
+line continuation inside parentheses, brackets and braces. Long lines
+can be broken over multiple lines by wrapping expressions in parentheses.
+These should be used in preference to using a backslash for line continuation.
+@end quotation")
+ (license license:asl2.0)))
+
(define-public python-flake8-implicit-str-concat
(package
(name "python-flake8-implicit-str-concat")