summaryrefslogtreecommitdiff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2021-04-09 16:13:57 +0200
committerRicardo Wurmus <rekado@elephly.net>2021-04-13 13:41:17 +0200
commitb1415bf089991f3eb5dfcaf26b40a0ac40b40ba3 (patch)
treeb9ce409952941ab4328b8d458530f1b902782b17 /gnu/packages/python-xyz.scm
parent2a12cbaaab970bcab09002e952e062da0274f0b6 (diff)
downloadguix-patches-b1415bf089991f3eb5dfcaf26b40a0ac40b40ba3.tar
guix-patches-b1415bf089991f3eb5dfcaf26b40a0ac40b40ba3.tar.gz
gnu: python-jupyter-client: Update to 6.1.12.
* gnu/packages/python-xyz.scm (python-jupyter-client): Update to 6.1.12. [propagated-inputs]: Add python-dateutil and python-tornado-6. [native-inputs]: Add python-pytest.
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm15
1 files changed, 9 insertions, 6 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 065a400945..30ab9f3251 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -7235,21 +7235,20 @@ without using the configuration machinery.")
(define-public python-jupyter-client
(package
(name "python-jupyter-client")
- (version "5.2.4")
+ (version "6.1.12")
(source
(origin
(method url-fetch)
(uri (pypi-uri "jupyter_client" version))
(sha256
(base32
- "0l9mh7ccrpl3lppym3dnky8n1nk7xarzzdcxf4q2s7aw203cpydm"))))
+ "10p7fcgvv9hvz9zical9wk68ks5ssak2ykbzx65wm1k1hk8a3g64"))))
(build-system python-build-system)
;; Tests fail because of missing native python kernel which I assume is
;; provided by the ipython package, which we cannot use because it would
;; cause a dependency cycle.
(arguments
`(#:tests? #f
-
#:phases (modify-phases %standard-phases
(add-after 'unpack 'set-tool-file-names
(lambda* (#:key inputs #:allow-other-keys)
@@ -7261,9 +7260,13 @@ without using the configuration machinery.")
(inputs
`(("iproute" ,iproute)))
(propagated-inputs
- `(("python-pyzmq" ,python-pyzmq)
- ("python-traitlets" ,python-traitlets)
- ("python-jupyter-core" ,python-jupyter-core)))
+ `(("python-dateutil" ,python-dateutil)
+ ("python-jupyter-core" ,python-jupyter-core)
+ ("python-pyzmq" ,python-pyzmq)
+ ("python-tornado" ,python-tornado-6)
+ ("python-traitlets" ,python-traitlets)))
+ (native-inputs
+ `(("python-pytest" ,python-pytest)))
(home-page "https://jupyter.org/")
(synopsis "Jupyter protocol implementation and client libraries")
(description