summaryrefslogtreecommitdiff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2022-07-29 17:50:56 +0100
committerEfraim Flashner <efraim@flashner.co.il>2022-08-05 21:08:49 +0300
commitb12da85668c40be322204e1ca04fb70b4d709411 (patch)
tree890febe0bfeac5aebaf400427d8112cb4eb3db62 /gnu/packages/python-xyz.scm
parent4fc41b4a9dbc422302bc44b7589722e43ec45cda (diff)
downloadguix-patches-b12da85668c40be322204e1ca04fb70b4d709411.tar
guix-patches-b12da85668c40be322204e1ca04fb70b4d709411.tar.gz
gnu: Add python-posix-ipc.
* gnu/packages/python-xyz.scm: (python-posix-ipc): New variable. Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm32
1 files changed, 32 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 622a356bf1..95467f4d52 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -29631,6 +29631,38 @@ sorted by priority and queues that are emptied in a round-robin
fashion.")
(license license:bsd-3)))
+(define-public python-posix-ipc
+ (package
+ (name "python-posix-ipc")
+ (version "1.0.5")
+ (source
+ (origin
+ ;; The source distributed on PyPI is prebuild.
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/osvenskan/posix_ipc")
+ (commit (string-append "rel" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "17y4d0pmvp199c5hbs602ailhlh9f9zv89kmpbd8jhyl6rgaxsvs"))))
+ (build-system python-build-system)
+ (arguments
+ (list #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'patch-cc-path
+ (lambda _
+ (substitute* "prober.py"
+ (("cmd = .cc")
+ (string-append "cmd = \"" #$(cc-for-target)))))))))
+ (native-inputs
+ (list python-unittest2))
+ (home-page "http://semanchuk.com/philip/posix_ipc/")
+ (synopsis "POSIX IPC primitives for Python")
+ (description
+ "This package provides POSIX IPC primitives - semaphores, shared memory and
+message queues for Python.")
+ (license license:bsd-3))) ; BSD like Copyright (c) 2018, Philip Semanchuk
+
(define-public python-itemadapter
(package
(name "python-itemadapter")