summaryrefslogtreecommitdiff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludovic.courtes@inria.fr>2020-02-10 18:25:43 +0100
committerLudovic Courtès <ludo@gnu.org>2020-02-10 23:31:58 +0100
commitae8db9ce327337b4e8a20a5082829b9ed1ef432c (patch)
tree3c72c7a7f530869f6a2aa27150bbf8ca4f07c571 /gnu/packages/python-xyz.scm
parent0690f3244ef207b64b85ee31f748e9a9106eb3da (diff)
downloadguix-patches-ae8db9ce327337b4e8a20a5082829b9ed1ef432c.tar
guix-patches-ae8db9ce327337b4e8a20a5082829b9ed1ef432c.tar.gz
gnu: pybind11: Add dependency on Catch and Eigen.
* gnu/packages/python-xyz.scm (pybind11)[inputs]: Add CATCH-FRAMEWORK2-1 and EIGEN. [arguments]: Add #:configure-flags.
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm15
1 files changed, 12 insertions, 3 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index bfd04c004c..e88ef25e90 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -1,6 +1,6 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2013 Nikita Karetnikov <nikita@karetnikov.org>
-;;; Copyright © 2013, 2014, 2015, 2016, 2017, 2018, 2019 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2013, 2014, 2015, 2016, 2017, 2018, 2019, 2020 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2013, 2014, 2015, 2016, 2019 Andreas Enge <andreas@enge.fr>
;;; Copyright © 2014, 2015 Mark H Weaver <mhw@netris.org>
;;; Copyright © 2014, 2017 Eric Bavier <bavier@member.fsf.org>
@@ -15408,9 +15408,18 @@ under Python 2.7.")
(build-system cmake-build-system)
(native-inputs
`(("python" ,python)
- ("python-pytest" ,python-pytest)))
+
+ ;; The following dependencies are used for tests.
+ ("python-pytest" ,python-pytest)
+ ("catch" ,catch-framework2-1)
+ ("eigen" ,eigen)))
(arguments
- `(#:test-target "check"))
+ `(#:configure-flags
+ (list (string-append "-DCATCH_INCLUDE_DIR="
+ (assoc-ref %build-inputs "catch")
+ "/include/catch"))
+
+ #:test-target "check"))
(home-page "https://github.com/pybind/pybind11/")
(synopsis "Seamless operability between C++11 and Python")
(description "pybind11 is a lightweight header-only library that exposes