summaryrefslogtreecommitdiff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-04-13 10:36:21 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-05-12 12:45:44 -0400
commitabb7617f204fe800cb19233101cb7334bfd1d0ff (patch)
tree57b973507898a52a53f07bdfb6427b6f43c22ae7 /gnu/packages/python-xyz.scm
parent0f446f1bc4cfc0752faa49efcd11914d7b4e977c (diff)
downloadguix-patches-abb7617f204fe800cb19233101cb7334bfd1d0ff.tar
guix-patches-abb7617f204fe800cb19233101cb7334bfd1d0ff.tar.gz
gnu: python-anyio: Replace python-pytest-trio with python-trio.
* gnu/packages/python-xyz.scm (python-anyio) [phases]{check}: Remove extraneous add-installed-pythonpath call. Expound comment about IPv6 issues. [native-inputs]: Use regular python-pytest. Replace python-pytest-trio by python-trio.
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm76
1 files changed, 38 insertions, 38 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index b573a7cd15..60c2e0e3cd 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -25610,43 +25610,44 @@ standard error channel (stderr) in your program.")
`(#:phases
(modify-phases %standard-phases
(replace 'check
- (lambda* (#:key inputs outputs tests? #:allow-other-keys)
+ (lambda* (#:key tests? #:allow-other-keys)
(when tests?
- (add-installed-pythonpath inputs outputs)
- (invoke "pytest" "-vv" "-p" "no:asyncio"
- "-m" "not network"
- "-k"
- (string-append
- "not test_is_block_device"
-
- ;; These fail because of network (or specifically
- ;; IPv6 network) access.
- " and not test_accept"
- " and not test_accept_after_close"
- " and not test_close_during_receive"
- " and not test_close_from_other_task"
- " and not test_concurrent_receive"
- " and not test_concurrent_send"
- " and not test_connect_tcp_with_tls"
- " and not test_connect_tcp_with_tls_cert_check_fail"
- " and not test_connection_refused"
- " and not test_extra_attributes"
- " and not test_getaddrinfo"
- " and not test_getnameinfo"
- " and not test_happy_eyeballs"
- " and not test_iterate"
- " and not test_receive_after_close"
- " and not test_receive_timeout"
- " and not test_reuse_port"
- " and not test_run_process"
- " and not test_send_after_close"
- " and not test_send_after_eof"
- " and not test_send_after_peer_closed"
- " and not test_send_eof"
- " and not test_send_large_buffer"
- " and not test_send_receive"
- " and not test_socket_options"
- " and not test_unretrieved_future_exception_server_crash"))))))))
+ (invoke
+ "pytest" "-vv" "-p" "no:asyncio"
+ "-m" "not network"
+ "-k"
+ (string-append
+ "not test_is_block_device"
+
+ ;; These fail because of network (or specifically IPv6
+ ;; network) access (see:
+ ;; https://github.com/agronholm/anyio/issues/417).
+ " and not test_accept"
+ " and not test_accept_after_close"
+ " and not test_close_during_receive"
+ " and not test_close_from_other_task"
+ " and not test_concurrent_receive"
+ " and not test_concurrent_send"
+ " and not test_connect_tcp_with_tls"
+ " and not test_connect_tcp_with_tls_cert_check_fail"
+ " and not test_connection_refused"
+ " and not test_extra_attributes"
+ " and not test_getaddrinfo"
+ " and not test_getnameinfo"
+ " and not test_happy_eyeballs"
+ " and not test_iterate"
+ " and not test_receive_after_close"
+ " and not test_receive_timeout"
+ " and not test_reuse_port"
+ " and not test_run_process"
+ " and not test_send_after_close"
+ " and not test_send_after_eof"
+ " and not test_send_after_peer_closed"
+ " and not test_send_eof"
+ " and not test_send_large_buffer"
+ " and not test_send_receive"
+ " and not test_socket_options"
+ " and not test_unretrieved_future_exception_server_crash"))))))))
(propagated-inputs
(list python-contextvars
python-dataclasses
@@ -25658,9 +25659,8 @@ standard error channel (stderr) in your program.")
python-coverage
python-hypothesis
python-mock
- python-pytest-6
+ python-pytest
python-pytest-mock
- python-pytest-trio
python-setuptools-scm
python-trio
python-trustme