summaryrefslogtreecommitdiff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
authorFranck Pérignon <franck.perignon@univ-grenoble-alpes.fr>2021-07-09 16:27:18 +0200
committerLudovic Courtès <ludo@gnu.org>2021-07-19 19:57:51 +0200
commitaa1b756723062739f6f205234276a8c6c47cf240 (patch)
tree213ba3c50afd2eb5f7afe1678df1d6e83437608c /gnu/packages/python-xyz.scm
parentde50ff13def0c84a4991fce28887dc76a1ab8d39 (diff)
downloadguix-patches-aa1b756723062739f6f205234276a8c6c47cf240.tar
guix-patches-aa1b756723062739f6f205234276a8c6c47cf240.tar.gz
gnu: Add python-pyhull.
* gnu/packages/python-xyz.scm (python-pyhull): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index d8c3fbec07..46419d4b45 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -105,6 +105,7 @@
;;; Copyright © 2021 Danial Behzadi <dani.behzi@ubuntu.com>
;;; Copyright © 2021 Maxime Devos <maximedevos@telenet.be>
;;; Copyright © 2021 Hugo Lecomte <hugo.lecomte@inria.fr>
+;;; Copyright © 2021 Franck Pérignon <franck.perignon@univ-grenoble-alpes.fr>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -26013,3 +26014,25 @@ result.")
"This packages provides a docutils-compatibility bridge to CommonMark,
enabling you to write CommonMark inside of Docutils & Sphinx projects.")
(license license:expat)))
+
+(define-public python-pyhull
+ (package
+ (name "python-pyhull")
+ (version "2015.2.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "pyhull" version))
+ (sha256
+ (base32
+ "091sph52c4yk1jlm5w8xidxpzbia9r7s42bnb23q4m4b56ihmzyj"))))
+ (build-system python-build-system)
+ (propagated-inputs
+ `(("python-numpy" ,python-numpy)))
+ (home-page "https://github.com/materialsvirtuallab/pyhull")
+ (synopsis "Python wrapper to Qhull")
+ (description
+ "This package provides a Python wrapper to @uref{http://www.qhull.org/,
+Qhull} for the computation of the convex hull, Delaunay triangulation, and
+Voronoi diagram.")
+ (license license:expat)))