summaryrefslogtreecommitdiff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2021-04-14 17:05:12 +0200
committerRicardo Wurmus <rekado@elephly.net>2021-04-14 17:15:23 +0200
commit9fd8f44bd7524399651ba677e93b5e4d36f8e524 (patch)
tree965bc2088fd3ca434c3c853f8dcfcab27017213d /gnu/packages/python-xyz.scm
parent3f3d66377c052d6121b46db53391614329fa4ffb (diff)
downloadguix-patches-9fd8f44bd7524399651ba677e93b5e4d36f8e524.tar
guix-patches-9fd8f44bd7524399651ba677e93b5e4d36f8e524.tar.gz
gnu: Add python-ld.
* gnu/packages/python-xyz.scm (python-ld): New variable.
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 9660f6ffd2..c01993ecd7 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -24618,6 +24618,27 @@ typographically-improved HTML. While often used in conjunction with Jinja and
Django template systems, the filters can be used in any environment.")
(license license:bsd-3)))
+(define-public python-ld
+ (package
+ (name "python-ld")
+ (version "0.5.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "ld" version))
+ (sha256
+ (base32
+ "1k4ydp5rgkv4985v459kcl06i1igjm1ywvh2vkbi9ck1zyyri1z5"))))
+ (build-system python-build-system)
+ (propagated-inputs
+ `(("python-six" ,python-six)))
+ (home-page "https://github.com/nir0s/ld")
+ (synopsis "OS platform information API")
+ (description
+ "The ld package provides information about the GNU/Linux distribution it
+runs on, such as a reliable machine-readable ID, or version information.")
+ (license license:asl2.0)))
+
(define-public python-pathvalidate
(package
(name "python-pathvalidate")