summaryrefslogtreecommitdiff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2021-05-06 15:50:16 +0200
committerMarius Bakke <marius@gnu.org>2021-05-06 19:10:04 +0200
commit9e22ab252f7c106f0aadcb697d22fa08eaf476e3 (patch)
treea2611a8a9463a12e9544157c032c3012843850a5 /gnu/packages/python-xyz.scm
parent47516f818e32438ad8edaaaab0c2661ca4092b32 (diff)
downloadguix-patches-9e22ab252f7c106f0aadcb697d22fa08eaf476e3.tar
guix-patches-9e22ab252f7c106f0aadcb697d22fa08eaf476e3.tar.gz
gnu: python-flake8: Do not delete and recreate check phase.
* gnu/packages/python-xyz.scm (python-flake8)[arguments]: Replace check phase instead of deleting. Remove trailing #t.
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm6
1 files changed, 2 insertions, 4 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index fbaec6ee92..75a0cc8db3 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -9009,12 +9009,10 @@ complexity of Python source code.")
(arguments
`(#:phases
(modify-phases %standard-phases
- (delete 'check)
- (add-after 'install 'check
+ (replace 'check
(lambda* (#:key inputs outputs #:allow-other-keys)
(add-installed-pythonpath inputs outputs)
- (invoke "pytest" "-v")
- #t)))))
+ (invoke "pytest" "-v"))))))
(propagated-inputs
`(("python-pycodestyle" ,python-pycodestyle)
("python-entrypoints" ,python-entrypoints)