summaryrefslogtreecommitdiff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2020-03-02 10:52:42 -0500
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2020-03-02 17:03:02 -0500
commit9c9704a9d73ef2002d792b1dd463e65dc68823ba (patch)
tree545190370df2d69e6a80dd0afa6bb6472d86d9fb /gnu/packages/python-xyz.scm
parent1eee899617cfd2216baba5be42e2c2d77f58715a (diff)
downloadguix-patches-9c9704a9d73ef2002d792b1dd463e65dc68823ba.tar
guix-patches-9c9704a9d73ef2002d792b1dd463e65dc68823ba.tar.gz
gnu: Add python-wget.
* gnu/packages/python-xyz.scm (python-wget): New variable.
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm19
1 files changed, 19 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 446eccd10f..8484600b6b 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -17475,6 +17475,25 @@ such as a file modification and trigger an action. This is similar to inotify,
but portable.")
(license license:asl2.0)))
+(define-public python-wget
+ (package
+ (name "python-wget")
+ (version "3.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "wget" version ".zip"))
+ (sha256
+ (base32
+ "0qb0y7ipby42m4m7h0ipazpdyc3bn9xi46lvifcwwl5albn31rim"))))
+ (build-system python-build-system)
+ (native-inputs `(("unzip" ,unzip)))
+ (home-page "https://bitbucket.org/techtonik/python-wget/")
+ (synopsis "Pure Python download utility")
+ (description "The python-wget library provides an API to download files
+with features similar to the @command{wget} utility.")
+ (license license:unlicense)))
+
(define-public offlate
(package
(name "offlate")