summaryrefslogtreecommitdiff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2022-01-31 15:41:13 +0100
committerRicardo Wurmus <rekado@elephly.net>2022-01-31 16:07:40 +0100
commit9686c828ed330a23357a8fd53e62ef9cdb7288ef (patch)
treee0d4981dc2157a20c32f8cb0edf52072f36f2607 /gnu/packages/python-xyz.scm
parentf383aca4086716b07f4e1f06df2aad4d7b796ebc (diff)
downloadguix-patches-9686c828ed330a23357a8fd53e62ef9cdb7288ef.tar
guix-patches-9686c828ed330a23357a8fd53e62ef9cdb7288ef.tar.gz
gnu: python-seaborn: Fix build.
* gnu/packages/python-xyz.scm (python-seaborn)[source]: Add patch. [arguments]: Add build phase 'patch-more-tests. * gnu/packages/patches/python-seaborn-2690.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it.
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm19
1 files changed, 18 insertions, 1 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 945f3319f1..cee7dab15a 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -9615,11 +9615,28 @@ SVG, EPS, PNG and terminal output.")
(uri (pypi-uri "seaborn" version))
(sha256
(base32 "1xpl3zb945sihsiwm9q1yyx84sakk1phcg0fprj6i0j0dllfjifg"))
- (patches (search-patches "python-seaborn-kde-test.patch"))))
+ (patches (search-patches "python-seaborn-kde-test.patch"
+ "python-seaborn-2690.patch"))))
(build-system python-build-system)
(arguments
`(#:phases
(modify-phases %standard-phases
+ (add-after 'unpack 'patch-more-tests
+ (lambda _
+ (substitute* "seaborn/tests/test_distributions.py"
+ (("get_contour_color\\(ax\\.collections\\[0\\]\\)")
+ "get_contour_color(ax.collections[0])")
+ (("c\\.get_color\\(\\)") "get_contour_color(c)")
+
+ ;; These three are borked and have been fixed upstream, but
+ ;; there's no simple patch we could apply here, so we just
+ ;; disable them.
+ (("def test_hue_ignores_cmap")
+ "def skip_test_hue_ignores_cmap")
+ (("def test_fill_artists")
+ "def skip_test_fill_artists")
+ (("def test_with_rug")
+ "def skip_test_with_rug"))))
(add-before 'check 'start-xserver
(lambda _
;; There must be a running X server and make check doesn't