summaryrefslogtreecommitdiff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2020-01-15 20:11:05 +0100
committerMarius Bakke <mbakke@fastmail.com>2020-01-15 20:36:33 +0100
commit8f137daf8af37a8f91f74370948fac3f01728a80 (patch)
treebf812f3dfb5c0e506977ee71dea6b1591c6f4d38 /gnu/packages/python-xyz.scm
parent6b3cef844c5b7c5628fba57e6aed42c56d06cbca (diff)
downloadguix-patches-8f137daf8af37a8f91f74370948fac3f01728a80.tar
guix-patches-8f137daf8af37a8f91f74370948fac3f01728a80.tar.gz
gnu: python-wheel: Update to 0.33.6.
* gnu/packages/python-xyz.scm (python-wheel): Update to 0.33.6. [arguments]: Explicitly disable tests (they never ran before). [native-inputs, properties]: Remove. (python2-wheel): Use PACKAGE-WITH-PYTHON2.
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm21
1 files changed, 9 insertions, 12 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 6cf1fdfa2b..9ad4609fb3 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -1908,18 +1908,20 @@ with sensible defaults out of the box.")
(define-public python-wheel
(package
(name "python-wheel")
- (version "0.32.3")
+ (version "0.33.6")
(source
(origin
(method url-fetch)
(uri (pypi-uri "wheel" version))
(sha256
(base32
- "1dhxl1bf18bx9szmqcnxbg6204hp3im8089q3hkwh5jfa6zh75q2"))))
+ "0ii6f34rvpjg3nmw4bc2h7fhdsy38y1h93hghncfs5akfrldmj8h"))))
(build-system python-build-system)
- (native-inputs
- `(("python-jsonschema" ,python-jsonschema)
- ("python-pytest-cov" ,python-pytest-cov)))
+ (arguments
+ ;; FIXME: The test suite runs "python setup.py bdist_wheel", which in turn
+ ;; fails to find the newly-built bdist_wheel library, even though it is
+ ;; available on PYTHONPATH. What search path is consulted by setup.py?
+ '(#:tests? #f))
(home-page "https://bitbucket.org/pypa/wheel/")
(synopsis "Format for built Python packages")
(description
@@ -1930,15 +1932,10 @@ packages will be properly installed with only the @code{Unpack} step and the
unpacked archive preserves enough information to @code{Spread} (copy data and
scripts to their final locations) at any later time. Wheel files can be
installed with a newer @code{pip} or with wheel's own command line utility.")
- (license license:expat)
- (properties `((python2-variant . ,(delay python2-wheel))))))
+ (license license:expat)))
(define-public python2-wheel
- (let ((wheel (package-with-python2
- (strip-python2-variant python-wheel))))
- (package (inherit wheel)
- (native-inputs `(("python2-functools32" ,python2-functools32)
- ,@(package-native-inputs wheel))))))
+ (package-with-python2 python-wheel))
(define-public python-vcversioner
(package